0

So my Ubuntu 15.04 was working fine. Then I used clonezilla to backup the OS partition to a USB external disk. Installed a new 1tb disk, then booted using a 15.04 Live USB disk and restore the image. I then resized the partition using Gparted, and created a swap partition that was 16GB (I have 8GB of RAM on my lappy) The first couple reboots worked fine and I was proud of myself of conquering this project like a boss. Then I rebooted and got this error

error: invalid magic number

error: you need to load the kernel first

Press any key to continue

After that I am returned to the grub menu. I can boot from the 3rd option down as illustrated in the picture.

enter image description here

When I boot from the 3rd option, everything looks normal. I am new to grub tinkering, but would like my system to boot like it previously did.....automatically.

Thanks!

  • Boot to the kernel .25, remove the other kernels, reboot and then upgrade again. – Raphael Oct 13 '15 at 6:29
0

My guess is that in a couple of weeks and regular updates this problem will fix itself. I've seen this before a couple of times. Something else you could try booting to this Boot Repair CD.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.