45

In ubuntu 11.04 there was a workaround using gconf-editor and setting key /apps/gnome_settings_daemon/plugins/xrandr/active to false.

However there is no such key in gconf-manager using ubuntu 11.10 (gnome 3).

1
  • 1
    For context, here is the workaround user28503 alluded to.
    – jpaugh
    Jan 11 '18 at 17:40
20

The new version of gnome-settings-daemon stores its configuration information in dconf rather than gconf.

To do the equivalent of what you were doing on 11.04, try the following:

  1. Install the dconf-tools package, and then run dconf-editor.
  2. In the tree on the left, navigate org -> gnome -> settings-daemon -> plugins -> xrandr.
  3. Uncheck the active checkbox.
11
  • 1
    I've fixed up the answer now. Would you mind marking it as accepted if it solved your problem? Oct 19 '11 at 1:23
  • 2
    The way to do this from the command line is: dconf write /org/gnome/settings-daemon/plugins/xrandr/active false
    – aculich
    Nov 7 '12 at 2:26
  • 1
    I found that w/ Ubuntu 13.04 it's also necessary to do dconf write /org/gnome/settings-daemon/plugins/media-keys/active false
    – Mark
    Aug 20 '13 at 20:46
  • 3
    @elgalu: doing this will disable all media keys - including volume up, down, screenshots, etc. Certainly not what the OP wanted.
    – Gui Ambros
    Jun 28 '14 at 21:28
  • 1
    Yes @GuiAmbros it sucks, i still have no solution for this issue on Ubuntu 14.04 Jul 1 '14 at 16:56
44

On Ubuntu 18.04, I found two different keybindings for SUPER+P, which can be disabled with dconf-editor.

First, you need to install dconf-editor, if it's not already installed. This can be done in the terminal with the following command:

sudo apt install dconf-editor

Then you can launch it from the terminal:

dconf-editor

Within dconf-editor:

  • Navigate to: /org/gnome/mutter/keybindings/switch-monitor
  • If the "Custom value" field contains ['<Super>p', 'XF86Display'], then:
    • Disable "Use default value"
    • In the "Custom value" field, type the following: []
  • Navigate to: /org/gnome/settings-daemon/plugins/media-keys/video-out
  • If the "Custom value" field contains '<Super>p', then:
    • Disable "Use default value"
    • In the "Custom value" field, delete everything.
4
  • 1
    This is just the same as the other answer.s
    – fosslinux
    May 22 '18 at 2:26
  • 9
    I don't agree. You have edited out an important info : the fact that my answer is specific to Ubuntu 18.04. Also, the accepted answer is irrelevant to 18.04, and none of the other answers fully fixes the issue with 18.04.
    – David
    May 22 '18 at 14:36
  • This worked on Bionic. Very annoying that there are two different settings for the same shrotcut. The mutter one worked for me
    – chaz
    Oct 12 '18 at 0:09
  • Thank you so much, this actually worked for me. At first i only had the media-keys/video-out disabled and it still was happening. I couldn't stand it. when I hit the combo accidentally (it's too close to my alt+p bind i use for paste mode in vim) it completely borks my multi monitor setup, requiring painful resetting.
    – Steven Lu
    Feb 12 at 22:16
8

In order to disable global <Super>p keybindings, and NOT any other media keys (tested in Ubuntu 15.04) I had to 'emtpy' the following dconf keys. I ran (in a terminal):

dconf write /org/gnome/settings-daemon/plugins/media-keys/video-out ''
dconf write /org/gnome/settings-daemon/plugins/media-keys/screenshot ''

Before, I searched with the next bash commands for values that contained '<Super>p':

b="/org/gnome/settings-daemon/plugins/media-keys/"
for i in `dconf list $b | sort`; do echo -n "$i: "; dconf read $b$i; done

To search all dconf keys, use the command:

dconf dump / | grep '<Super>p'

If you want to avoid the terminal, run the program dconf-editor and search for the key(s) there...

Edit:

After some upgrades and restarts, I had the keybinding not working any more. I found, that there is/was a bug in gnome-settings-daemon that defines <Super>p. A hack is described here.

In the startup process, /usr/bin/xbindkeys_autostart is executed on login. This script searches for the file in $HOME/.xbindkeysrc and loads the settings.

Since I wanted to map gnome-screenshot -c to <Super>p, I created the this file with the following content (and unmapped the settings in ubuntu/compiz):

# Content of $HOME/.xbindkeysrc
"gnome-screenshot -c"
mod4 + p
3
  • 2
    Lovely! you finally solved my Super+P nightmare Feb 13 '15 at 21:16
  • @LeoGallucci, if you have problems after restarts/updates, try the .xbindkeysrc modification (see the edit of my answer).
    – setempler
    Feb 14 '15 at 13:28
  • The linked solution was exactly what I needed. Thanks!
    – legoscia
    Feb 11 '16 at 16:45
7

This is still an issue as of Ubuntu 12.10 released October 18, 2012. A bug fix for this seemed to be in the works so that at least there is an easier way to re-configure the key bindings, but it has since been marked invalid because this was supposedly fixed in gnome-settings-daemon.

Ultimately this problem is supposedly due to some hardware vendors hard-coding video out to Super-P.

There have been updated conversations on the bug tracker since the currently-accepted answer that suggest not turning off xrandr, but instead turning off media-keys:

Try the following:

  1. Install the dconf-tools package, and then run dconf-editor.
  2. In the tree on the left, navigate org -> gnome -> settings-daemon -> plugins -> media-keys.
  3. Uncheck the active checkbox.

Or the command-line version of this is:

dconf write /org/gnome/settings-daemon/plugins/media-keys/active false

1
  • This disables a lot more than just <super>P. If you just want to disable that, go to the location above, find video-out, and just change that. Doing this answer is throwing out the baby with the bathwater.
    – mlissner
    Oct 3 '17 at 16:56
6

Here's how to disable it with gsettings from your terminal

gsettings set org.gnome.mutter.keybindings switch-monitor "[]"

If you want to restore the shortcut

gsettings set org.gnome.mutter.keybindings switch-monitor "['<Super>p']"
2
  • 1
    I come from a mac environment where Command + P opens vscode search panel. And in ubuntu I got frustrated cause everything it would change displays. This works for me on Ubuntu 20.04. Apr 2 at 9:57
  • 1
    This is the answer for Ubuntu 20 Jul 23 at 18:36
3

Even if disabling the xrandr plugin isn't working for you (like me), I suggest you to try this (it works for me):

Go in the dconf-editor via the command "dconf-editor" in a terminal, then go at:

/org/gnome/mutter/keybindings/switch-monitor

and disable "use default value" and delete:

'<Super>p',

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.