3

Approximately a month ago my laptop stopped showing the Grub menu on startup. I had used this guide http://ubuntuforums.org/showthread.php?t=2227580 to setup my dual boot.

bcdedit /set "{bootmgr}" path \EFI\ubuntu\shimx64.efi

Has not fixed the issue like it did when I updated to windows 10 a while ago.

I have run boot repair using a live usb of ubuntu. http://paste.ubuntu.com/12684245/

Any help with how to resolve this issue would be greatly appreciated!

  • It sounds like the MBR of Windows has overwritten Grub. Have you tried EasyBCD (non-commercial edition) to edit your bootloader yet? – Dooley_labs Oct 12 '15 at 14:34
  • If it's an EFI-mode boot, the MBR is irrelevant. (The paste.ubuntu.com site is inaccessible to me right now, so I can't check it to verify this detail.) – Rod Smith Oct 12 '15 at 23:10
1

First you will have to disable hibernation and Fast Boot in your Windows 10 installation.
Boot into Windows, open command prompt as administrator and execute this command:

powercfg /h off  

To disable Fast Boot open Control Panel (the old version - not the modern design),
select the Energy Settings, enable show hidden settings and uncheck Fast Boot.

Shutdown the machine (do NOT reboot) completely.

Reinstall the GRUB bootloader to your Ubuntu installation in EFI mode.
Boot from the Ubuntu install media - then open a terminal and execute:

sudo mount /dev/sda8 /mnt
sudo mount /dev/sda2 /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
sudo chroot /mnt
grub-install /dev/sda
update-grub  

Note : sda = disk | sda2 = efi partition | sda8 = system partition | (taken from pastebin output)

Boot into BIOS and change the boot order in UEFI settings.
Select Ubuntu to be the default operating system to boot.
Now you can select which system to boot from GRUB menu.

I recommend to not use any 3rd party tools as they may bring along issues in some time later on !

  • 1
    Im probably missing something here but after i type the command sudo mount /dev/sda2 /mnt/boot/efi i get the error message mount: mount point /mnt/boot/efi does not exist – Owen M Oct 12 '15 at 17:39
  • @OwenM : Your pastebin output shows sda2 as EFI partition, so when you execute all commands exactly as described, it should work. This is why I recommend to not use any 3rd party tools - it seems your EFI partition is "a little bit corrupted". It is quite easy to delete the partition and create a new one from ubuntu install media, but do you know how to reinstall the Windows boot loader afterwards ? So first better try again : boot from ubuntu install media ... Post back the results - I will be back in about 12 hours - good luck my friend ! :) – cl-netbox Oct 12 '15 at 18:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.