0

I am using an NC-6220 Hewlett Packard keyboard with Linux Ubuntu 14.04 and to type the " and @ symbols I need to use the keys (plus shift) as though they were swapped round (eg. SHIFT+2 for @ and SHIFT+' for ") - what do I do to swap them back to the positions printed on the plastic?

It is OK for me to use because I am used to it, but if someone else is using my console, it is a headache for them and it is an accessibility issue to the 'net for folk who are not as computer-literate as me (not very computer-literate myself, actually !)

The "F" key isn't working either, but that's because it was glued back on with too much super-glue !!

I know I did something wrong when I set up the computer upon first installing Linux Ubuntu, and when I used the Guest Account the keys produce the right symbols.

I will give a million blessing points to anyone who can tell me, how I can assign specific characters to the keys on my keyboard.

:)

0

How to define keyboard layout https://help.ubuntu.com/community/Custom%20keyboard%20layout%20definitions

| improve this answer | |
  • Thanks DnrDevil. That has been a good launchpad for me to find a solution. In the end I discovered how to use the System Settings - Text Entry to add alternative keyboard layouts and now I am using a normal English (UK) layout which, for some reason, I failed to select when I installed Ubuntu. Everything seems to be working fine now. – Rene Thomas Oct 17 '15 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.