0

I am an Ubuntu 14.04 User, and I was trying to install Ubuntu on my tablet following the official instructions (https://developer.ubuntu.com/en/start/ubuntu-for-devices/installing-ubuntu-for-devices/), but when I tried to use adb for the android backup with this command:

$ adb backup -apk -shared -all 

or for unlocking the tablet with this other one:

$ adb reboot bootloader 

I got this: "error: device not found".

When I write down this one:

& adb devices

I get nothing. Nevertheless, the tablet appears as connected (in the tablet and the laptop).

I was wondering if anyone knows how to solve this. I am still pretty new with Ubuntu, and I haven't found any type of solution yet although I have been trying many different options.

By the way, the tablet is a BQ Maxwell 2 Plus (with Andorid 4.1.1), if it is important to know.

Thanks!

P.D.: I tried to connect my phone too. This time with root permissions (sudo), but it was also not found (BQ Aquaris E5 HD with Android 5.0).

  • Have you modified the udev rules? Also, FYI android.stackexchange.com – earthmeLon Oct 11 '15 at 22:45
  • I will check that, thanks @earthmeLon :) – Eneko Alvarez Oct 12 '15 at 10:24
  • I have not modified udev rules, and I think I do not know how to do that. I am pretty much of a noob... I have tried to modify them but I did not succeeded. – Eneko Alvarez Oct 12 '15 at 11:00
0

Nevermind, finally I was able to do it on my own. I had to edit the file HOME/.android/adb_usb.ini, and add "0x2207" there (in the last line). When I plugged the tablet I used "$ adb devices" and it was there, so problem solved. I copy the link here just in case it is useful for someone else.

http://www.slatedroid.com/topic/41219-connecting-to-a-rk3066-based-board-via-adb-on-linux/

Thanks!

P.D.: udev rules where modified, but I was looking somewhere else. Thanks anyway @earthmeLon

0

Not sure this solution is absolute, but you probably hadn't enabled the Android debug option available in the developer software.

Step 1 -> Go to Parameters -> About Phone, now scroll down to "build number" and tap seven times on it. This will enable Developers options and show the corresponding field in your Parameters.

Step 2 -> Go to Parameters -> Developers Options, and scroll down until you find android debugging. Enable it.

Your phone should now be listed when using sudo adb devices in terminal.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.