2

I've been messing around all day trying do dual-boot Ubuntu 15.04 64-bit on my Dell XPS 12-9Q33 running Windows 10. I'm running into roadblocks everywhere however, so I thought I'd see if anyone with knowledge about these sorts of things had any advice for me!

Anyway, here are the steps I've taken so far:

  • Shrunk my Windows partition

  • Created a bootable USB with Ubuntu 15.04 64bit using the Universal USB Installer.

  • Disabled hibernation entirely, presumably disabling Fast Boot.

  • Disabled Secure Boot

  • Tried with 2 different USB sticks, in both USB ports

No matter what I try, I just can't get my computer to recognize that there is a bootable USB available! This is in UEFI mode, of course - switching to legacy mode immediately lets the computer recognize the bootable USB, but will presumably create problems with the bootloader.

The only two boot options available in the setup/BIOS are 'Windows [something or other, I forget exactly]' and 'UEFI OS'. Selecting either of those options boots to Windows.

So, any ideas? Thanks so much for your time!

Daniel

  • /UEFI, /legacy, Ubuntu supports legacy even better than UEFI, it has both UEFI and BIOS mode, UEFI and BIOS bootloaders. – Star OS Oct 11 '15 at 11:43
  • It sounds almost like you didn't make an EFI bootable USB. What are you using to make the USB sticks? – TheWanderer Oct 11 '15 at 12:36
  • Many UEFI systems require a separate setting to allow USB (or any other device) boot. See if you have that setting somewhere. Often best to have secure boot off, but UEFI on, and CSM/BIOS/Legacy mode off. – oldfred Oct 11 '15 at 14:42
1

Your Ubuntu installation media seems to be improperly configured regarding the bootability.

When you have an already existing Ubuntu installation - recreate your installation media by:

  1. Open built-in Disks tool – click the menu (right top corner) - select Restore Disk Image.
  2. Choose the Ubuntu iso image - select the USB drive to write it to and start the process.

In case you have to do it from within Windows - open command prompt as administrator.

  1. Create your Ubuntu USB installation media by executing the following commands:

    diskpart  
    list disk  
    select disk ¹  
    clean  
    create partition primary  
    active  
    format fs=fat32 quick  
    assign letter=²  
    exit  
    
  2. Mount the Ubuntu iso file and copy the content to the USB drive.

Notes:
¹ = select the USB drive
² = choose a free drive letter

|improve this answer|||||
  • Thank you! It appears that Universal USB Installer does NOT create a UEFI compatible bootable image. Using 'rufus' instead worked perfectly. – user3379936 Oct 12 '15 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.