1

what Happened - I installed audacity (programme) through command line. Help file was missing. I download zip file. Came to know that this file has to be stored in /usr/share folder. When I tried to extract it there, it was failing. I thought its permission problem so changed permission of /usr/share as following

sudo chmod -R ugo=rwx /usr/share

Within few minits after this system started behaving strangely. Then it collapsed. Nothing was happening. Only black screen was there.

So, I forced shutdown but pushing power button and then restarted the system. It went well till BIOS screen, showed the colored Ubuntu letters and in seconds again went blank.

What I tried?

So to solve this I first looked for answeres on "black screen" after BIOS. Almost all of them suggesting that there must be so problem with graphics card. I was not sure about it, so I tried to see if changes in permission has caused some problem. This question has raise relatively similar issue. But as system was down and there was no screen at all I was not knowing where to put the commands. Additionally it was different in two ways - it speaks about /usr/bin and not /usr/share and in my case sudo was working fine. In this situation, with some research, I tried typing "ctrl+alt+f1" and now I was able to see tty1 type. I am root on this machine and as said earlier sudo was working fine. Now, I tried the combination of suggestions I found in above mentioned question and also here and here and here.

Commands like shutdown now or reboot or even sudo reboot were not working. PC was not shutting down.

I did sudo pkexec it came with some message saying I should go to look for help and disable internal agent and [username] PROGRAMME [Argument]

I gave repair command, I it came up with permission error 13 Tried sudo apt-get update it also came with permission error 13, access denied. There was one more message Sorry, command-not-found has crashed! Please file a bug report at Most of the questions addressing this issue discuss about problem caused by locale.

Now I am unable to "capture" the outcomes of the commands as it is in tty1 mode and the outputs are too long to remember. In this situation what will help me in rebooting to normal mode?

  • 3
    change back the permission of /usr/share to original. You cant simply give world permission to /usr/share, it also being use by other system utility. – Aizuddin Zali Oct 11 '15 at 12:45
  • @AizuddinZali , thanks, but then, what is original permission. I do not know it! – sangharsh Oct 11 '15 at 14:30
  • 1
    If the answer below helped you, don't forget to click the grey at the left of its text, which means Yes, this answer is valid! ;-) – Fabby Oct 13 '15 at 18:14
  • @Fabby I have up-voted the answer but have not accepted it yet. I up-voted it as it address the issue. I have not accepted it yet as another method which is less tedious solved by problem. I will write that as answer. – sangharsh Oct 14 '15 at 12:07
2

The easiest thing to to right now is to:

  1. Boot a LiveDVD of the same version of Ubuntu you're currently running
  2. Install the same back-up program you took your back-up with
  3. Update to the same level as your computer was before it had the problem.
  4. restore the file permissions only (not the files themselves)

Done! ;-)

100% satisfaction guaranteed!

Oh??? You don't have a back-up??? Well... then you'll only have an 85% chance of success so still use step 1 but:

  1. Go and buy a back-up hard drive
  2. make a back-up of your computer
  3. execute the following commands

    cd /media/ubuntu/LargeImpossibleNumber/usr/share
    sudo chown --recursive root:root *
    

2 and 3 here above are very important if you happen to fall into the bad 15% as the above might make things worse and you might lose everything and then you'll need to reinstall everything and then restore your data...

  • 1
    Don't thank me! ;-) If this answer did help, just click the little grey under the "0" now turning it into beautiful green. If you do not like the answer, click on the little grey down-arrow below the 0, and if you really like the answer, click on the little grey ☑ and the little up-arrow... If you have any further questions, just ask another one! – Fabby Oct 11 '15 at 23:30
0

Yes, and I got the answer. In away, its quite simple. As @Aizuddin Zali suggest the way out is through setting "right" permission for /usr/share again. But then, what is "right permission" (or say standard)? I tried to search for it without much help when I dashed on this question and its answer. Though it is not speaking directly about /usr/share I tried to use the same permissions and it worked!! I will try to explain this in detail.

What I did (already discussed in question):

As I explain it in question, with the help of Karnel ( ctrl+alt+t ), I changed the permission of directory /usr/share. I did it with recursive command (R). What Happended: System collapsed.

Solution which I found:

I closed the PC forcefully by pressing and holding power key. Then I started it by pressing it again. As usual BIOS screen appeared. Colord UBUNTU letters also appeared for while and they diappeared. Then there was nothing. I pressed Ctrl+Alt+F1 . tty1 started. There I typed my login name (it was admin account) and then password. Now I changed the permission of /usr/share to drwxr-xr-x . The commands I used were For knowing the current status:

sudo ls -l /usr/share

which gave me list of permissions in the directory. Then,

sudo chmod -R u=rwx /usr/share

sudo chmod -R go-w /usr/share

(Which restricted the permission to "write" for g(group) and o(other).)

sudo chmod -R go=rx /usr/share

Now the output of

sudo ls -l /usr/share

was

drwxr-wr-w

Then,

sudo reboot

The pc heard this. (Pc was not hearing reboot or "shutdown now" commands previously even as sudo) And then it stared, loggin screen appeared too. Hopefully, whatever I did was right! One thing I am sure about - it restated the system. So I am thankful to @falconer in particular and community in general. Please let me know if I have done something wrong.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.