0

My WiFi connection keeps switching between different access points,

I have already set my regulatory domain to be explicit and I have set IPv6 to Ignore in the Network Manager

I have also bound my access point in the Network Manager icon, by filling in in the MAC address for my access point.

Still it keeps switching different access points!

You can find my wireless script output here

  • actually, I guess the repeater channels are supposed to stay on the same channel which is odd because I've seen roaming channels broadcast on varying channels such as the ones at the university or even the "cable wifi" public channels. – mchid Oct 11 '15 at 15:30
  • You say you have set the BSSID in network-manager. What is the output of the following command: ls /etc/NetworkManager/system-connections – mchid Oct 11 '15 at 15:36
  • this is the output;131 erez sdf telenet-33857 +6 Familie Bzl sdfq telenet-377BC 651 HTC Portable Hotspot C308 sdqf telenet-apn-A9D84 ds IG-Intern sfd TELENETHOMESPOT ds 1 J_G SNOW5_34 TELENETHOTSPOT dv Mobistar-3294 sqdf TTK-E2 – jozef Oct 11 '15 at 15:41
  • this is a better way to look at it; paste.ubuntu.com/12752627 – jozef Oct 11 '15 at 15:44
  • If the answer below helped you, don't forget to click the grey at the left of its text, which means Yes, this answer is valid! ;-) – Fabby Oct 13 '15 at 18:14
1

First of all, delete all the networks from /etc/NetworkManager/system-connections that you don't want to connect to. In fact, if you don't mind setting up your existing connection again, you can go ahead and delete everything in this directory. As it is now, network-manager remembers all the networks you have connected to in the past and so it is trying to connect to familiar networks automatically.

The following commands will move these to a backup directory in your home directory:

mkdir ~/wifibackup
sudo mv /etc/NetworkManager/system-connections/* ~/wifibackup

Now, restart network-manager:

sudo service network-manager restart

You will need to reestablish your connection to the network. After doing so, set the BSSID in network-manager and remember to restart network-manager to apply the settings after you do.


Also, I found some posts and have seen a lot of people have wireless issues because of a conflicting module. So, if the above isn't enough try running the following commands to resolve the issue:

sudo modprobe -r acer_wmi
cp /etc/modprobe.d/blacklist.conf /etc/modprobe.d/.blacklistbackup
echo "blacklist acer_wmi" | sudo tee -a /etc/modprobe.d/blacklist.conf 
  • How can i do this? – jozef Oct 11 '15 at 15:12
  • This din't work, it keeps switching between the different access points named "TELENETHOMESPOT" – jozef Oct 11 '15 at 21:33
  • Then set the BSSID to a static value and remember you must reconnect to the network after doing so to apply the changes or it won't work. – mchid Oct 12 '15 at 4:44
  • @jozef Also, you can try setting your IP to a static value. After obtaining an IP through DHCP, set that IP to a static value, along with netmask and gateway. I think DNS usually works when set to the same as gateway but if not you can use 8.8.4.4 or opendns or whatever. Again, after making these changes, reconnect to the network by clicking on it to refresh the new settings. Hopefully, even if you do roam, you won't have to go through the hassle of obtaining a new IP each time. – mchid Oct 12 '15 at 5:03
  • @jozef click on connection information to obtain the proper addresses. – mchid Oct 12 '15 at 5:04
1

What you're describing is behaviour by design!

I suppose TELENETHOMESPOT is a network of hot spots set up by an ISP using residential routers so that when you're not at home, but near another customer of that same ISP, you can pick up their network.

Well now, that is the same thing large companies do with multiple antennas all broadcasting the same SSID, but on different channels depending on where in the building you are...

However, in a large company, they're all on the same network, and that's where your issue comes in: if the ISP didn't make this one big roaming network (which wouldn't surprise me as it's a HOMESPOT and not a HOTSPOT) you're actually switching between vastly different networks with each their own DHCP server instead of one vast network with only one DHCP server which is really annoying!

Therefore the only solution for such a residential HOMESPOT network is to go and sit as close to one of the routers as possible! Alternatively, call the ISP and ask them if they have a real HOTSPOT network available and having experience with quite a few ISPs all over EMEA, that'll be an extra payable service...

  • 1
    And poor implementation on the part of the ISP because they are all on the same channel. – mchid Oct 12 '15 at 4:59
  • :D Extremely probable! @mchid – Fabby Oct 12 '15 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.