Here are the specs on my desktop computer:

I5 processor 24 GB Ram 256GB SSD NVIDIA GTX Titan X

I just migrated this system over from Windows 7 64 bit to Ubuntu 14.04.3 LTS 64 bit, to match my laptop. This issue is that I have 3 monitors connected to my desktop and every time I click on Screen Display in System Settings the System Settings windows just closes. The first couple of times it gave me a crash error and the window just started to close. I have clicked on other items in the System Settings window and they open fine, it is just this that is giving me issues.

I tried changing the driver under Additional Drivers in the Software & Updates window from "Using X.Org..." to "Using NVIDIA binary driver..." (the one that said tested at the end of it) and when I rebooted the computer all 3 screens went to sleep and I was unable to do anything with them (I was able to get into safe graphics mode and change it back). I also tried downloading the Linux driver 64 bit version from the NVIDIA site itself, but that seemed to save a .run file and I tried to run it in a terminal window with no luck, not sure what to do with it.

I also have installed the NVIDIA X Server Settings, but do not seem to see anything in there regarding my card or settings. The only two items listed on the left hand side are:

"Application Profiles" "nvidia-settings Configuration"

As well I installed xfce4-display-settings and ran xfce4-display-settings -m and in there changed my screen settings, in the window that opened, to the way that I wanted, but it did not seem to make any difference.

Any and all help would be greatly appreciated. :)

  • Welcome to Ask Ubuntu! ;-) Could you please go to a terminal by pressing [Ctrl][Alt][T] and type sudo lshw. Then edit your question and copy-paste the output of the command into your question so we can see what exact hardware you have. also a copy of your monitors.xml pasted to paste.ubuntu.com would be nice. Then leave a comment @Fabby. – Fabby Oct 11 '15 at 21:40

As you are using very new GPU hardware, it is recommended to use the very latest stable drivers.

Install the latest stable NVIDIA drivers supporting TITAN X from the Proprietary GPU drivers PPA.

Before you install new drivers uninstall every NVIDIA related software you have installed before.

Open a terminal and execute :

sudo apt-get purge nvidia*  
sudo reboot

Then install the latest current stable NVIDIA drivers from the short-lived branch by executing :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-355 
sudo reboot  

In case you are using a notebook with a hybrid graphics solution install Optimus support as well.

sudo apt-get install nvidia-prime

To switch between intel and nvidia graphics - open NVIDIA X Server Settings -> Prime Profiles.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.