0

I want test Budgie Desktop on my Ubuntu 15.04 64 bits PC but i can't install due some problems; So, i tried install from several ways:

  1. Official PPA: In several guides to install Budgie say that in order to install it type in terminal the commands:

    sudo add-apt-repository ppa:evolve-os/ppa
    sudo apt-get update
    sudo apt-get install budgie-desktop
    

    The repository adds successfully. Now, i type the last command sudo apt-get install budgie-desktop but returns

    Unable to locate package budgie-desktop

  2. Also i tried build it myself using this commands:

    sudo apt-get install build-essential gnome-common gobject-introspection libglib2.0-dev libgtk-3-dev libpulse-dev libpulse-mainloop-glib0 libmutter-dev libwnck-3-dev libupower-glib-dev libgnome-menu-3-dev libc6-dev
    git clone https://github.com/evolve-os/budgie-desktop.git
    cd budgie-desktop
    ./autogen.sh
    make 
    sudo make install
    

    However returned:

    make: No rule to make target 'install'. Stop.
    
  3. .deb File:

    After search a lot of guides about this on the web, i found a .deb file available to download, so i downloaded and i open it with Ubuntu Software Center.

    But the Software Center doesn't allowed me install saying the next message:

    The dependency cannot can be satisfied: libupower-glib1
    

    So i go to Synaptic to search it but didn't found the package.

  4. Searching in Synaptic.

    Also i tried search the package itself in Synaptic, but wasn't there!.

Recommendation of similar desktops are welcome.

0

According to the ppa, budgie is not currently available for your Ubuntu version.

Here's a snapshot:

1

Also, if you really want to install the DE then force install the package using the following command, this will also tell you about all the dependencies. So, then you can install them individually later.

sudo dpkg -i --ignore-depends=package_name package_name.deb

EDIT:

Well regarding libupower-glib1, its available under archive.ubuntu.com, i.e., it should be available by default. Here is a screenshot to confirm that:

12

And about libmutter0d, you are in bad luck, because Launchpad Ubuntu status shows it to be deleted. Here is a screenshot:

13

  • When i execute these command returned a message saying that budgie-desktop requires the packages "libupower-glib1" and "libmutter0d". But i don't know how get it. I tried sudo apt-get install libupower-glib1&&sudo apt-get install libumutter0d but returned the next message: the package libmutter0d isn't available. Same with libpower-glib1. – edr-01 Oct 12 '15 at 1:53
  • Edited the answer you may check again. – Raphael Oct 12 '15 at 9:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.