10

I'm trying to install a framework using curl but I keep getting this annoying error message curl: (1) Protocol https not supported or disabled in libcurl. Does any one know how to fix this? I'm stack!

Thanks

2
  • Edit your question and add the output of apt-cache policy curl libcurl3 – A.B. Oct 10 '15 at 16:16
  • did you use official cURL or the one manually compiled? By default cURL https support is enabled in official release. – Aizuddin Zali Oct 10 '15 at 17:13
8

I managed to fix the issue after some hours of trying various options! Here's what I did:

Downloaded from http://curl.haxx.se/download.html.

tar -xzf curl-***.tar.gz
cd curl-*.*.*
./configure --with-ssl
make
sudo make install
1
  • You will also need to install open-ssl before you do the above commands. Otherwise ssl is still disabled. sudo apt install libssl-dev – Rock Apr 3 '19 at 19:15
1

Officially cURL does not support HTTPS. The answer above didn't work for me, already tried download new versions added with --with-ssl command and got no lucky, this answer solved my problem.

https://stackoverflow.com/a/28782797/8146700

  • Content link -

I still don't know why using Aptitude installs a version without support for HTTPS but building from scratch did the trick:

git clone https://github.com/bagder/curl.git sudo apt-get build-dep curl cd curl ./buildconf ./configure make sudo make install

Now curl -V yields

Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp smb smbs smtp smtps telnet tftp Features: IDN IPv6 Largefile NTLM NTLM_WB SSL libz TLS-SRP UnixSockets

1
  • It is generally better to include the main steps you followed in your answer here, with a link to the answer that worked for you - just in case the link goes dead. – sempaiscuba Aug 18 '17 at 20:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.