After updating Ubuntu a few days back my ethernet has stopped working. The wifi works fine. I even managed to make my ethernet work once using sudo dhclient eth0 but could not replicate it after reboot. I have another laptop with Windows and the physical cable is fine.

My ethernet connection gets connected but internet doesn't work. Also I am behind a proxy if that helps in anyway.

I have posted this after reading a lot of fixes on the internet. None of them seem to even temporarily fix my problem.

Any help would be appreciated.

Here are a few outputs :

ifconfig

eth0  Link encap:Ethernet  HWaddr 14:dd:a9:0d:88:29  
      inet addr:172.24.136.242  Bcast:172.24.143.255  Mask:255.255.248.0
      inet6 addr: fe80::16dd:a9ff:fe0d:8829/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:1443 errors:0 dropped:3302 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:161427 (161.4 KB)

lo    Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:28333 errors:0 dropped:0 overruns:0 frame:0
      TX packets:28333 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:2407338 (2.4 MB)  TX bytes:2407338 (2.4 MB)

wlan0 Link encap:Ethernet  HWaddr 34:02:86:96:f3:98  
      inet addr:192.168.63.102  Bcast:192.168.63.255  Mask:255.255.255.0
      inet6 addr: fe80::3602:86ff:fe96:f398/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:27733 errors:0 dropped:0 overruns:0 frame:0
      TX packets:23098 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:19054557 (19.0 MB)  TX bytes:4802812 (4.8 MB)

cat /etc/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by   resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
search connectify

cat /etc/network/interfaces

auto lo
iface lo inet loopback

lspci | grep Ethernet

05:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd.    RTL8111/8168/8411
PCI Express Gigabit Ethernet Controller (rev 12)

Update:

The answer below used to temporarily start my internet once in a while but didn't fix it permanently. So eventually after a couple of regular minor updates from Ubuntu my ethernet started working again. So I guess if the common solutions on the internet don't work and your ethernet stopped working just after an update you should probably wait for the next update.

  • 1
    Why does your ethernet have a 172.xx address while your wireless has 192.xx? Are they connected to the same router or...?? – chili555 Oct 10 '15 at 15:22
  • It is probably because the laptop is connected to the internet using connectify. – imhobo Oct 10 '15 at 21:51
up vote 1 down vote accepted

open /etc/network/interfaces using

sudo vi  /etc/network/interfaces

add line

auto eth0 
iface eth0 inet dhcp 

then do

sudo ifdown eth0
sudo ifup eth0

you are saying sudo dhclient eth0 working so do above change it will search for DHCP when you start system also make sure you have proper proxy setting in your system .current ifconfig output shows your system getting IP from DHCP.

EDIT: For device not managed you have to open /etc/NetworkManager/NetworkManager.conf using command :

sudo vi /etc/NetworkManager/NetworkManager.conf

and change the line managed=false to managed=true and restart NetworkManager

sudo service network-manager restart

For more info related this problem you can take help from Askubuntu another question network manager says “device not managed”

  • 1
    So I did what you suggested. After rebooting my loading screen said something like " Waiting for network configuration" and after a minute it said " Booting without full network configuration" . After booting my network manager was stopped. So I started it using "sudo service network-manager start" and then it showed "device not managed" below my ethernet network. – imhobo Oct 10 '15 at 21:49
  • If I remove the 2 lines you suggested from /etc/network/interfaces then the "device not managed" message disappears. – imhobo Oct 10 '15 at 21:50
  • Here is a cropped snapshot of "device not managed" message. link – imhobo Oct 10 '15 at 21:55
  • @imhobo i have added to my answer please check – pl_rock Oct 11 '15 at 3:36
  • Hey thank you. Changing "managed=false" temporarily started my internet and also removed the "device not managed" message. But it is still not working after reboot. I now have a new ethernet connection called "IfUpDown (eth0)" which doesn't connect whereas my orignal "Auto Ethernet" connects but doesn't run the internet. – imhobo Oct 12 '15 at 9:16

Ethernet fix after Ubuntu update:

  1. Execute the below command in terminal:

    sudo -H gedit /etc/network/interfaces
    
  2. Add the below two lines ( the primary network interface) and save:

    auto eth0
    
    iface eth0 inet dhcp
    
  3. Execute the below command in terminal:

    sudo nano /etc/udev/rules.d/70-persistent-net.rules
    
  4. The above command will open editor inside terminal, you will find the below lines present (if not please add these):

    ATTR{address} is your adapter mac address and NAME="eth0"

    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="0a:03:27:c2:b4:eb", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
    
  5. Save and reboot.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.