2

This question already has an answer here:

My host OS is Ubuntu 15.04 and my guest OS is Windows 10. I'm running VirtualBox 5.0.2 r102096.

When the guest OS is running in the VM, right-clicking on the little USB icon displays a context menu with a single disabled menu item that says No USB devices connected.

When the machine is powered off and I go into its settings, on the USB tab, the Enable USB controller option is checked and USB 3.0 (xHCI) Controller is selected. In the USB device filters list some of my previously created (from when it still worked) filters are present and when I right-click there and select Add filter from device, I am greeted with a similar context menu with a single disabled menu item that says No devices available.

My USB flash drive is inserted into the host computer, but other devices should be visible as well, namely the integrated webcam, the touchscreen and stuff. They were previously, before either upgrading Ubuntu or upgrading VirtualBox, I cannot pin point precisely when it stopped working as I run the guest OS sporadically.

When I run sudo adduser tomashubelbauer vboxusers, I get The user tomashubelbauer' is already a member ofvboxusers'. When I log out and log in again, the same thing happens.

Are there any other knows issues with VirtualBox being unable to enumerate USB devices? Are there other options for me to troubleshoot the issue further?

marked as duplicate by karel, Eric Carvalho, Zanna, Tom Brossman, Thomas Nov 11 '18 at 10:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did you install VirtualBox Extension Pack? – Pilot6 Oct 10 '15 at 10:54
  • Oracle VM VirtualBox Guest Additions are installed in the guest OS in version 5.0.2. To my understanding, though, that shouldn't play a role for the little USB icon and the device filter list displayed by VirtualBox itself in the host OS. – Tomáš Hübelbauer Oct 10 '15 at 10:58
  • I am not asking about guest additions. – Pilot6 Oct 10 '15 at 10:59
  • Sorry, I though the two refer to a same thing. I'll look into it and check back. Thanks for the tip. – Tomáš Hübelbauer Oct 10 '15 at 11:00
2

You need to install VirtualBox Extension Pack.

For version 5.0.2 it can be found HERE

And also version 5.0.2 is a bit outdated. You need to upgrade to version 5.0.6. and install the Extension Pack.

  • @TomášHübelbauer Done. – Pilot6 Oct 10 '15 at 11:28
1

For anyone experiencing this issue while having $USER in vboxusers, what helped for me was just to upgrade VirtualBox to the latest version (5.0.6 at the time of writing).

VirtualBox's update check didn't work for me in 5.0.2 (content access network error, apparently a known issue) so I suspect it didn't upgrade automatically, so I had to do it myself.

Also, @Pilot6 was technically right about VirtualBox Extension Pack having to be installed for USB 2.0 and USB 3.0 and VirtualBox itself prompted me to upgrade Extension Pack right after I upgraded the software itself, so credit goes to him as well.

Not the answer you're looking for? Browse other questions tagged or ask your own question.