1

I hope you can help me. I'm not a Ubuntu Pro so I will need help with this.

Basically my Wireless Connection is not working correctly.

As stated above my laptop contains the Intel Wireless AC-7260 adapter.

The behaviour is very different.

At home I can connect to the wireless connection, but after 1 minute or so I can't connect to the internet. The wireless connection is strong (4 out of 5).

I tried different stuff:

  1. I used "sudo lshw -c network" to get the correct name of the product.

  2. I install the iwlwifi-7260-ucode-25.30.14.0.

  3. I followed some other advises here on the forum but nothing changed.

(I wanted to insert the link, but the connection went down as I was writing...)

I don't know if it is relevant but I have a dual boot system (ubuntu 14.04 and windows 8.1). On Windows the connection is better, but also drops. Sometimes it gets the connection back up but most of the time not. Sometimes I have problems to connect to certain networks (eduroam, maybe some people know it). In that case on the Ubuntu side it won't connect at all and on Windows you have to have luck. On my phone its never a problem to connect and have a stable connection.

The other problem is that I currently can not log into the router to try to play with some configuration. It's not mine and I do not have the password for it, but I am working on that issue.

Is there any way how you can help me?

Maybe you can help me with those questions too:

  1. Is there a way to get a more detailed view on the wireless connection? (like with bandwidth, send/received/lost packages, maybe mode which are used)

  2. If there is not a good solution I am thinking about buying an external wireless device (maybe USB). I haven't had the internet yet to check for some products, but maybe you already had the pleasure to test some. Any advice is welcome!

  3. Are there know issues with my wireless adapter and certain routers?

As said before any advice is helpful.

I also contacted Intel directly to see if they can tell my anything to do to fix the problem (I'm not putting alot of hope into that way but well at least you have to try).

Thank you in advance!

Regards,

accname

3
  • 2
    Possible duplicate of Wifi losing connection, weak signal, Intel 7260 adapter
    – Pilot6
    Oct 9, 2015 at 23:24
  • Got to admit, I oversaw that post. Tried the commands and will report back if it helped. Thanks Pilot6 for sharing the link! Oct 10, 2015 at 12:19
  • I tried the recommended options in the post and tested them. The 11n_disable setting made it better but I still lose the connection from time to time. Oct 11, 2015 at 22:41

1 Answer 1

0

This might be the answer you are looking for since it just helped me out and I had the EXACT same problem. Go here: http://linuxwireless.org/en/users/Drivers/iwlwifi/ and download the right driver version for you. Use:

wget -then the link-
tar -xzcf iwlwifi
cp -the ilwifi driver- /lib/firmware
sudo reboot

the documentation is on linuxwireless website's.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .