When I tried to install
sudo apt-get install python3-dev I got the following message
python3-dev : Depends: libpython3-dev (= 3.4.0-0ubuntu2) but it is not going to be installed Depends: python3.4-dev (>= 3.4.0-0~) but it is not going to be installed E: Unable to correct problems, you have held broken packages.
So I tried installing dependencies
libpython3-dev then I got this message
The following packages have unmet dependencies: libpython3.4-dev : Depends: libpython3.4-stdlib (= 3.4.0-2ubuntu1.1) but 3.4.3-1ubuntu1~14.04.1 is to be installed Depends: libpython3.4 (= 3.4.0-2ubuntu1.1) but 3.4.3-1ubuntu1~14.04.1 is to be installed E: Unable to correct problems, you have held broken packages.
However both the dependencies are already installed.I'm using Ubuntu 14.04
When I ran the
apt-cache policy python3.4 I got
python3.4: Installed: 3.4.3-1ubuntu1~14.04.1 Candidate: 3.4.3-1ubuntu1~14.04.1 Version table: *** 3.4.3-1ubuntu1~14.04.1 0 100 /var/lib/dpkg/status 3.4.0-2ubuntu1.1 0 500 http://in.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages 500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages 3.4.0-2ubuntu1 0 500 http://in.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages