10

When I tried to install python3-dev using sudo apt-get install python3-dev I got the following message

python3-dev : Depends: libpython3-dev (= 3.4.0-0ubuntu2) but it is not going to be installed
           Depends: python3.4-dev (>= 3.4.0-0~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

So I tried installing dependencies libpython3-dev then I got this message

The following packages have unmet dependencies:
 libpython3.4-dev : Depends: libpython3.4-stdlib (= 3.4.0-2ubuntu1.1) but 3.4.3-1ubuntu1~14.04.1 is to be installed
                    Depends: libpython3.4 (= 3.4.0-2ubuntu1.1) but 3.4.3-1ubuntu1~14.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

However both the dependencies are already installed.I'm using Ubuntu 14.04

When I ran the apt-cache policy python3.4 I got

    python3.4:
    Installed: 3.4.3-1ubuntu1~14.04.1
  Candidate: 3.4.3-1ubuntu1~14.04.1
  Version table:
 *** 3.4.3-1ubuntu1~14.04.1 0
        100 /var/lib/dpkg/status
     3.4.0-2ubuntu1.1 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     3.4.0-2ubuntu1 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
8
  • Which ubuntu version? Try apt-get clean all then try again. – Aizuddin Zali Oct 9 '15 at 19:34
  • Still the same error – iLoveCamelCase Oct 9 '15 at 19:36
  • How did you invoke the command? Make sure your system is up-to-date. – Aizuddin Zali Oct 9 '15 at 19:38
  • What command? I used sudo apt-get clean all – iLoveCamelCase Oct 9 '15 at 19:38
  • I mean when u try to install. – Aizuddin Zali Oct 9 '15 at 19:39
6

The solution is to wait for the Ubuntu developers to re-upload Python 3.4.3 to the updates repository. This should happen any day now. Keep your eyes on bug #1348954.

Edit: Fixed. Installing python3-dev works again.

2

Okay So I went through this and temporarily solved the problem by forcefully downgrading my python

apt-get install -y \
  python3.4=3.4.0-2ubuntu1.1 \
  python3.4-minimal=3.4.0-2ubuntu1.1 \
  libpython3.4-stdlib=3.4.0-2ubuntu1.1 \
  libpython3.4-minimal=3.4.0-2ubuntu1.1

Edit: After this reinstall stdlib as it misses some libraries. Removing python3 might remove some packages of your desktop environment reinstall the desktop environment in that case.

I had some issues with lightdm after this. Before removing print the removed packages and reinstall them with new python 3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.