0

I have a Wireless 3945ABG [Golan] network adapter in my Gateway NX570X laptop. I just installed Ubuntu 14.04. Ethernet works but wifi doesn't. I've tried several methods to try to get it working but it didn't help at all. I think there may be a problem with the card itself. But I can't understand what the code from dmesg is saying. I don't have any hardware off switch; but i do have the keyboard combo switched on, the LED is on for wifi. It is not hard or soft blocked. Thanks for any help!

lshw output:

*-network DISABLED
   description: Wireless interface
   product: PRO/Wireless 3945ABG [Golan] Network Connection
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlan0
   version: 02
   serial: 00:1b:77:1a:57:5c
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwl3945 driverversion=3.19.0-30-generic firmware=15.32.2.9 latency=0 link=no multicast=yes wireless=IEEE 802.11abg
   resources: irq:29 memory:d6000000-d6000fff

dmesg output:

[ 2952.041767] iwl3945 0000:03:00.0: Microcode SW error detected. Restarting 0x82000008.
[ 2952.041785] iwl3945 0000:03:00.0: Loaded firmware version: 15.32.2.9
[ 2952.041820] iwl3945 0000:03:00.0: Start IWL Error Log Dump:
[ 2952.041825] iwl3945 0000:03:00.0: Status: 0x000202E4, count: 1
[ 2952.041829] iwl3945 0000:03:00.0: Desc       Time       asrtPC  blink2 ilink1  nmiPC   Line
[ 2952.042057] iwl3945 0000:03:00.0: SYSASSERT     (0x5) 0000006495 0x008B6 0x10A4E 0x00320 0x00000 216
[ 2952.042057] 
[ 2952.042074] iwl3945 0000:03:00.0: Error Reply type 0x000000FF cmd C_RXON (0x10) seq 0x0401 ser 0x00030000
[ 2952.042092] iwl3945 0000:03:00.0: Command C_RXON failed: FW Error
[ 2952.042104] iwl3945 0000:03:00.0: Error setting new configuration (-5).
[ 2952.043867] iwl3945 0000:03:00.0: Can't stop Rx DMA.
[ 2952.044244] ieee80211 phy0: Hardware restart was requested
0

Hey what have you already tried? A few steps would be to manually turn off and restart in terminal. Please update with wifi trouble shooting you have done to better help you.

sudo ifdown interface

sudo ifup interface

sudo iwlist scan

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.