0

I'm trying to use virt-manager (0.9.5) on an Ubuntu server (version 14.04). I can connect to the Ubuntu server. I connect to the Ubuntu server via Putty, TurboVNC, or via the IP Management Interface with a web browser and connect via a remote console. When I use the virt-manager command, I go to the next command line. There is no error and nothing pops up. I configured Putty to Enable X11 forwarding. The /etc/ssh_config and /etc/sshd_config files are configured to allow X11 forwarding. libvirt and xterm have been installed. virsh list shows VMs running.

"virt-manager --debug" returns an error about "Unable to initialize GTK: could not open display"

Why cannot I see a pop up after I use the virt-manager command when I am root? I desire to have a GUI pop up to create a VM.

Update: Xserver was already installed on the laptop. I changed the repositories the Ubuntu server pointed to and upgraded virt-manager to 1.2 with an apt-get command. Don't apt-get commands install necessary dependencies? virt-manager still isn't working. The upgrade worked (virt-manager --version proves it). But this following command shows libosinfo is 2.9-1:

apt-cache policy libosinfo-1.0.0

I thought virt-manager 1.2 required libosinfo to be at 2.10.

virt-manager still doesn't work. Why isn't virt-manager working? If libosinfo wasn't installed properly with the apt-get install virt-manager command, how do I upgrade libosinfo?

  • do you have X-server running on your computer? – Jakuje Oct 8 '15 at 22:32
  • On the Linux server or the Windows laptop? How do I tell for sure? – Catbird55 Oct 9 '15 at 0:21
  • I had it installed the whole time. I found that when it is properly installed, it doesn't have an entry in the "Uninstall Programs" section of Windows. I reinstalled it for good measure. But the problem remains. Why did this question get downvoted? I disagree that every how-to has a section for installing X-Server. – Catbird55 Oct 9 '15 at 15:47
  • Other possibility is that the X forwarding is disabled on server. – Jakuje Oct 9 '15 at 18:24
  • How would I test for this? /etc/ssh_config and sshd_config were configured appropriately as far as I know how to tell. I examined them closely too. – Catbird55 Oct 9 '15 at 20:48
0

You need to have X server installed on you windows laptop. If you didn't install it on you windows laptop, you don't have it. It is part of every how-to.

  • It was already installed. – Catbird55 Oct 9 '15 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.