I shared a folder with samba. Access is allowed only with username and password. If I try to access from Windows or Android, I always get a failure on the first try and a success from the second on.

This is my /etc/samba/smb.conf:

# Sample configuration file for the Samba suite for Debian GNU/Linux.
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which 
# are not shown in this example
# Some options that are often worth tuning have been included as
# commented-out examples in this file.
#  - When such options are commented with ";", the proposed setting
#    differs from the default Samba behaviour
#  - When commented with "#", the proposed setting is the default
#    behaviour of Samba but the option is considered important
#    enough to be mentioned here
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic 
# errors. 

#======================= Global Settings =======================


## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
    workgroup = WORKGROUP

# server string is the equivalent of the NT Description field
    server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
    dns proxy = no

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;   interfaces = eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;   bind interfaces only = yes

#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
    log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
    max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
#   syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
    syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
    panic action = /usr/share/samba/panic-action %d

####### Authentication #######

# Server role. Defines in which mode Samba will operate. Possible
# values are "standalone server", "member server", "classic primary
# domain controller", "classic backup domain controller", "active
# directory domain controller". 
# Most people will want "standalone sever" or "member server".
# Running as "active directory domain controller" will require first
# running "samba-tool domain provision" to wipe databases and create a
# new domain.
    server role = standalone server

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.  
;   passdb backend = tdbsam

    obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
    unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
    pam password change = yes

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
    map to guest = bad user

########## Domains ###########

# The following settings only takes effect if 'server role = primary
# classic domain controller', 'server role = backup domain controller'
# or 'domain logons' is set 

# It specifies the location of the user's
# profile directory from the client point of view) The following
# required a [profiles] share to be setup on the samba server (see
# below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
# (this is Samba's default)
#   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
#   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

# This allows machine accounts to be created on the domain controller via the 
# SAMR RPC pipe.  
# The following assumes a "machines" group exists on the system
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

# This allows Unix groups to be created on the domain controller via the SAMR
# RPC pipe.  
; add group script = /usr/sbin/addgroup --force-badname %g

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is disabled.
;   usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
    usershare allow guests = yes
    username map = /etc/samba/smbusers

#======================= Share Definitions =======================

# Un-comment the following (and tweak the other settings below to suit)
# to enable the default home directory shares. This will share each
# user's home directory as \\server\username
;   comment = Home Directories
;   browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
;   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
;   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.
# Un-comment the following parameter to make sure that only "username"
# can connect to \\server\username
# This might need tweaking when using external authentication schemes
;   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

    comment = All Printers
    browseable = no
    path = /var/spool/samba
    printable = yes
;   guest ok = no
;   read only = yes
    create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
    comment = Printer Drivers
    path = /var/lib/samba/printers
;   browseable = yes
;   read only = yes
;   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# You may need to replace 'lpadmin' with the name of the group your
# admin users are members of.
# Please note that you also need to set appropriate Unix permissions
# to the drivers directory for these users to have write rights in it
;   write list = root, @lpadmin

    path = /home/mauro/Pubblici
    writeable = yes
;   browseable = yes
    valid users = mauro

This is /var/log/samba/log.smdb : http://pastebin.com/W30hmKnQ

Here you are with a log from the first failed attempt:

[2015/10/15 11:38:01.010825,  2] ../source3/param/loadparm.c:3582(do_section)
  Processing section "[printers]"
[2015/10/15 11:38:01.011051,  2] ../source3/param/loadparm.c:3582(do_section)
  Processing section "[print$]"
[2015/10/15 11:38:01.011139,  2] ../source3/param/loadparm.c:3582(do_section)
  Processing section "[Pubblici]"
[2015/10/15 11:38:01.035299,  2] ../source3/auth/auth.c:278(auth_check_ntlm_password)
  check_ntlm_password:  authentication for user [mauro] -> [mauro] -> [mauro] succeeded
[2015/10/15 11:38:01.037346,  1] ../source3/auth/token_util.c:430(add_local_groups)
  SID S-1-5-21-1432355103-2748604540-3142755518-1000 -> getpwuid(4294967295) failed
[2015/10/15 11:38:01.037433,  1] ../source3/smbd/sesssetup.c:276(reply_sesssetup_and_X_spnego)
  Failed to generate session_info (user and group token) for session setup: NT_STATUS_UNSUCCESSFUL

User permissions:

sudo pdbedit -L -v
Unix username:        mauro
NT username:          
Account Flags:        [U          ]
User SID:             S-1-5-21-1432355103-2748604540-3142755518-1000
Primary Group SID:    S-1-5-21-1432355103-2748604540-3142755518-513
Full Name:            mauro
Home Directory:       \\mauro-m14xr1\mauro
HomeDir Drive:        
Logon Script:         
Profile Path:         \\mauro-m14xr1\mauro\profile
Domain:               MAURO-M14XR1
Account desc:         
Munged dial:          
Logon time:           0
Logoff time:          mer, 06 feb 2036 16:06:39 CET
Kickoff time:         mer, 06 feb 2036 16:06:39 CET
Password last set:    mar, 16 set 2014 14:13:30 CEST
Password can change:  mar, 16 set 2014 14:13:30 CEST
Password must change: never
Last bad password   : 0
Bad password count  : 0
  • Do you get an error message on the first try? – user.dz Oct 12 '15 at 18:46
  • 1
    Sure. On Android (es file explorer) I get this error: i.stack.imgur.com/6zEE4.png On windows xp I get this: i.stack.imgur.com/FYTvc.gif – jasmines Oct 13 '15 at 10:14
  • Do you have firewall set by any chance? – Arup Roy Chowdhury Oct 15 '15 at 8:24
  • no firewall, and this would not explain why the second attempt is a success. Always, and immediately. – jasmines Oct 15 '15 at 9:13
  • added some log, see if it helps – jasmines Oct 15 '15 at 9:39

The only difference I can see, in the global config, between the smb.conf I have on my desktop (which works fine) and your config, is the line:-

username map = /etc/samba/smbusers

So my question is do you need it? Is the file correct? Are you connecting with the correctly mapped user?

What does /var/log/samba/ contain? Normally there is a file named according to the attempted connection. You should be able to find the reason it declined the connection in one of those.

If you can find the appropriate log message, post it in your question, if you can't make sense of it


I checked and by default the log level = 0 which means it doesn't put much of use in the log files. Authentication errors need a log level of 2 at least. So I suggest you try adding

log level = 2

To the [global] section of the config file above (I put it within the Debugging/Accounting section), and try again. You should get a file log. created, with the clients IP, showing what if any it tried to connact as. My guess, is it's making an initial attempt as 'guest', which your share name in the config above, doesn't allow.

In my test, with the above config, I get the following:-

[2015/10/14 13:56:29.851320,  2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
  check_ntlm_password:  Authentication for user [guest] -> [guest] FAILED with error NT_STATUS_NO_SUCH_USER


[2015/10/14 13:51:12.307610,  2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
  check_ntlm_password:  Authentication for user [user1234] -> [user1234] FAILED with error NT_STATUS_WRONG_PASSWORD

And for a correct login I get the following:-

[2015/10/15 12:44:32.343347,  2] ../source3/auth/auth.c:278(auth_check_ntlm_password)
  check_ntlm_password:  authentication for user [user1234] -> [user1234] -> [user1234] succeeded
[2015/10/15 12:44:32.351284,  2] ../source3/smbd/reply.c:592(reply_special)
  netbios connect: name1=LOCALHOST      0x20 name2=HOSTNAME12340x0
[2015/10/15 12:44:32.351337,  2] ../source3/smbd/reply.c:633(reply_special)
  netbios connect: local=localhost remote=hostname1234, name type = 0

All of which taken from log. when using

smbclient -L localhost -U <username>

Ok, with hindsight, your log included this line:-

[2015/10/15 11:38:01.037346,  1] ../source3/auth/token_util.c:430(add_local_groups)
  SID S-1-5-21-1432355103-2748604540-3142755518-1000 -> getpwuid(4294967295) failed

the bit getpwuid(4294967295) failed is listed in https://bugzilla.samba.org/show_bug.cgi?id=10604 as an issue in samba > version 4.1.7 It seems there is an issue with samba (winbind) returning -1 (aka 4294967295) when it fails to lookup things.
There is a patch in bugzilla (to the source) or apparently a change to the config, to add

idmap config * : range = 1000-1999999 

Prevents winbind from returning the error.

It all sounds a bit unlikely, but their summary matches yours, so it's probably right.

  • removal of that line does not solve the issue – jasmines Oct 14 '15 at 7:37
  • Stupid question, but you have tried restarting the samba server? With that line removed, you have basically the same config file as my computer here, and I have no problem accessing it from windows machines (I don't have an android on the network), without an initial disconnect. The only other suggestion, is to clear the samba cache and tdb files (from /var/cache/samba) and start again. – sibaz Oct 14 '15 at 8:14
  • cache deleted and server restarted. Same as above. – jasmines Oct 14 '15 at 10:08
  • I added my /var/log/samba/log.smdb file. There's no log file related to the failed access. On the second try, that is a success, a log file is generated and it's empty. – jasmines Oct 14 '15 at 10:16
  • Sadly, I can't see pastebin from work. So will have to take a look when I get home tonight. If you can see log lines that relate to the attempted connection in log.smbd or log.nmbd, but they don't make sense, you might want to try increasing the logging level. I'll have to look from home to see if I can make sense of the log – sibaz Oct 14 '15 at 12:02

Things to do so you can capture what goes wrong during the first connection.

  1. Increase log level momentarily to 3 or 5
  2. Add Wireshark on your windows machine and listen to your network traffic only between the two IP addresses (client and server)
  3. Capture the packets on the server side as well using tcpdump

I believe it is something that has to do with connection establishing between client - server, before it even reaches user authentication point.

Question: Samba version? Windows OS? Linux OS? Give me some numbers :-P

This logs should tell you exactly what is going on. Post the important parts of the logs here.

If you need any help upload the logs somewhere and let me have a look.

Good luck!

  • windows xp, ubuntu 15.04, samba 2:4.1.13+dfsg-4ubuntu3 can't go depth with wireshark/tcpdump things as I'm not so skilled even with log level 5 no log file is created on the first failed attempt – jasmines Oct 15 '15 at 9:12
  • That is strange. I am not sure how the old samba version creates the logs. Is there no log for your client's IP address? For example /var/log/samba/__your_IP_ ? As for the wireshark session just capture all the packets at the moment you are trying to access the samba share the first time. Feel free to upload it somewhere and I can have a look at it. – koullislp Oct 15 '15 at 9:25
  • already told: /var/log/samba/__your_IP_ is created only after the second attempt – jasmines Oct 15 '15 at 9:35
  • added some log, see if it helps – jasmines Oct 15 '15 at 9:39
  • Your log doesn't say anything. Did you change log level? Try 'log level = 5' and then try connecting the first time. – koullislp Oct 20 '15 at 9:40

I was able to work around this issue by creating a user mapping in smbusers from the smb account to the unix account. In my case the accounts had the same name, so my smbusers looks like:

# Unix_name = SMB_Name1 SMB_Name2 ...
root = administrator
nobody = guest smbguest pcguest
bobssmbact = bobsmbact  # add lines like these

Make the change then:

> service samba restart.

There is a bug report on this issue here: https://bugzilla.samba.org/show_bug.cgi?id=10604


I don't know if this is the solution, but I have started setting up a Samba Server, and in all the tutorials I've seen, they all say to have security = user in the [global] definition. It is supposed to typically come commented in the .conf file. It didn't for me, so I was told to add that, ideally below the ###Authentication header. That may work for you.

  • security = user is the default... – jasmines Oct 18 '15 at 4:17
  • From what I was told, security = user is disabled by default. I don't see it anywhere in your configuration file. – Rohan Oct 18 '15 at 4:29
  • samba official reference doesn't say anything about this – jasmines Oct 18 '15 at 12:48
  • I don't know about the official reference, but I'm going off the Ubuntu Server 14.04 Guide. – Rohan Oct 18 '15 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.