1

I've installed ubuntu 14.05 32 bit on my netbook. Then I've got the languages like I need them - desktop in English, plus Russian for writing documents. Worked perfectly in Unity. I downloaded lxde because unity was too slow, though, and in lxde I just cant manage to change the language for typing. I tried adding that "keyboard layout switcher" app to the task bar, but Russian doesn't show anywhere in its settings, only US does. How can I set up lxde to freely switch between languages, or how can I at least add Russian to that keyboard layout switcher app?

0

I assume that you have installed 14.04 since there is no 14.05. It is relatively easy to add another language. Since you had it working in Unity I will also assume that you have also successfully downloaded and installed the Russian language pack.
There should be a two letter code or a flag in your LXPanel. Right click whichever one you have and select "Keyboard Layout Handler" settings. When the new window opens, uncheck "keep system layouts" which is located on the right side of the window. Then select "Add" which will be on the left side of the window. A list will appear. Scroll down to Russian. It will be "ru". Select it and move it up or down wherever you want it. Before you close the window you must re-check "keep system layouts." The you can close the window. A new session is required for you new settings to take effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.