I just installed Ubuntu 14.04 on an old PC and the input devices are behaving strangely.

My "Enter" key is accepted on the first boot screen but once Ubuntu is launched neither the keyboard nor the mouse will respond.

This was tested with a wired as well as wireless keyboard and mouse.

  • ah, are the correct drivers installed? try to access via remote and show us lsmod and lshw. Oct 7, 2015 at 17:34

2 Answers 2


Since your keyboard appears to work at boot here's what I suggest: (i) send your system into recovery mode from the GNU GRUB menu, (ii) drop to a root shell prompt, and finally, (iii) issue a command to reinstall / install input device drivers. This should help you gain keyboard and mouse access for accessing the Ubuntu desktop.

Let's start by booting into recovery mode.

Follow the below instructions which I've grabbed from the Ubuntu Wiki Recovery Mode page:

  1. Switch on your computer.
  2. Wait until the BIOS has finished loading, or has almost finished. (During this time you will probably see a logo of your computer manufacturer.)
  3. Quickly press and hold the Shift key, which will bring up the GNU GRUB menu. (If you see the Ubuntu logo, you've missed the point where you can enter the GRUB menu.)
  4. Select the line which starts with "Advanced options".
  5. Select the line ending with "(recovery mode)", probably the second line, something like:

    Ubuntu GNU/Linux, with Linux 3.8.0-26-generic (recovery mode)

  6. Press Return and your machine will begin the boot process.
  7. After a few moments, your workstation should display a menu with a number of options. One of the options (you may need to scroll down to the bottom of the list) will be "Drop to root shell prompt". Press Return with this option highlighted.

You should now be at the root shell prompt.

There's a semi-related Ask Ubuntu question about the keyboard and mouse locking after suspend. I believe this question's accepted answer to reinstall or install input device drivers should help resolve the issue.

From the shell prompt type the following:

sudo apt-get install xserver-xorg-input-all 

In case that doesn't work, try:

sudo apt-get install --reinstall xserver-xorg-input-all

Once the command completes, reboot your system:

sudo reboot now

If all went well you should now be able to access the Ubuntu desktop with your input devices.

  • Nice explanation. But maybe bootoption nomodeset would work,too. I also would give booting an older Kernel a try. In addition to this I would search for the keyboard drivers. (lsmod) but vote up! Oct 8, 2015 at 17:43
  • @LittleByBlue, correct me if I'm wrong, but I believe the nomodeset GRUB option is for resolving video driver and blank screen issues encountered during boot up. Do you have information on how it could fix input device-related problems? Additionally, it'd be handy if you could share details for your suggestion to boot an older Kernel. Your comment about using lsmod for diagnosing things is a useful one. Otherwise, awaiting news from the asker on where things stand in their troubleshooting.
    – mheadroom
    Oct 8, 2015 at 20:09
  • nomodeset tells the kernel to load the modules at a later point of boot. this is often used in combination with nvidia graphics. somtime older kernels do have other std-modules (modules, that are always loaded into the kernel). Oct 10, 2015 at 7:33

Thanks to mheadroom,

I tried the procedure (very detailed) but ran into a wall at the

sudo apt-get install --reinstall xserver-xorg-input-all

command which gave me something (originally in french 'cause I'm french) :

Lock not used for the file /var/lib/dkpg/lock read only

So I finally decided to reinstall from scratch (I had nothing special to recover from the boot drive I use), but I specified to format both the / and the the /boot directories I put on different partitions and to leave my /home partition where it was before without re-formatting it). Both are on 2 separate SSD disks.

It's working fine now (even I was a bit anxious at the beginning because the two cores - it's a very old Coe 2 Duo @2 Ghz - were both running at 100%).

Things calmed down after a while : only the teamviewer process I installed is taking about 5-15% CPU time.

I'll be able to use this PC for light tasks.

Thanks anyway for your help which can be useful to use in some spécifica cases (I didn't know anything about the recovery mode).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.