Possible Duplicate:
Appearance does not change on switching the theme

I recently upgraded to Ubuntu 11.10 and it has been a headache ever since. I have gnome-tweak-tools installed, CCSM is configured to work well with Unity, and I have tried each the three built-in Unity themes.

My problem is that when I change the theme, only the window border changes. The icons don't change (on the panel and otherwise), Nautilus still looks ugly, scroll-bars don't change, etc. Everything looks very plain, boxy, and Windows 98-like. I didn't have any of these problems with Ubuntu 11.04 (of course I wasn't using Unity then).

enter image description here

marked as duplicate by jrg Feb 23 '12 at 15:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you add a link to a screenshot? – fossfreedom Oct 17 '11 at 18:23
  • @JorgeCastro Possibly, but my desktop never even shows the theme, not even slightly. sudo gnome-settings-daemon results in changed icons (sometimes for awhile sometimes it ends immediately after closing terminal) but Nautilus and menus are still bad. – metalnick Oct 17 '11 at 21:37
  • Well, certainly running g-s-d as sudo is going to make it worse, as now it's writing files in your home directory that your user account can't access. – Jorge Castro Oct 17 '11 at 21:43
  • Yes, but that was something that a user tried to do so I thought I might as well give it a go. The only thing the top-rated answer did for me was to lock up my touchpad. – metalnick Oct 17 '11 at 22:31

My answer to this exact same problem was to create a new user account and them move over none system files, then to carefully replace any . files.

The issue is caused by Nautilus or the setting daemon crashing during logon and then nautilus cannot ever get a path to the required theme.

There is a file in your user directory that is causing the problem.

Now that I have a working platform I'll do a trial and error search to see if I can find the offending file.


It is mostly because gnome-settings-daemon is not running.

Can you make sure that your have the latest version of this package. I can find this old bug about it

  • I typed gnome-settings-daemon in a terminal and got this:** (gnome-settings-daemon:24877): WARNING **: Name taken or bus went away - shutting down. I tried sudo apt-get install gnome-settings-daemon and was notified that I have the latest version. – metalnick Oct 17 '11 at 18:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.