1

enter image description here

Its a fresh install of 14.04. I've done the obvious sudo apt-get update but stil not working. Im seriously new to ubuntu so please explain what you want me to do (Thanks alot in advance!)

10
  • Welcome to Ask Ubuntu. Can you please edit your question with the full error message ?
    – hg8
    Oct 7 '15 at 9:09
  • So sorry, my image didnt work. Edited.
    – AndyGUY
    Oct 7 '15 at 9:11
  • it's a fresh install, have you performed an apt-get update and an apt-get upgrade?
    – mchid
    Oct 7 '15 at 9:19
  • @mchid i hadnt done upgrade, but i just have.. still nothing :(
    – AndyGUY
    Oct 7 '15 at 9:27
  • Will you give a text output of these commands: sudo apt-get upgrade, sudo apt-get update and sudo apt-get dist-upgrade. You might have to run them more than once to get all the needed updates and upgrades. You can use the select and copy command and paste the content between <pre></pre> marks. Using the preformatted markup will preserve the format that you see on your screen. Oct 7 '15 at 9:47
0

I think you have to enable the universe and multiverse repositories in order to get a clean install of gnome-shell on 14.04 because of all the dependencies. If you would like to add these repositories, run the following commands:

First, make a backup:

sudo cp /etc/apt/sources.list /etc/apt/backupsources

Then, edit the file:

sudo sed -i 's/main/main universe multiverse /g' /etc/apt/sources.list

Next, update your package list:

sudo apt-get update

Now, you have two options. First, you could install using apt-get:

sudo apt-get install eog gnome-shell

Alternatively, it's much easier to install a default desktop on a system that does not yet have an xserver by using tasksel to automate the process somewhat.

First, install tasksel:

sudo apt-get update
sudo apt-get install tasksel

Next, run tasksel, follow the on screen instructions, use the arrow keys to navigate, the spacebar to select or un-select, and the enter as normal.

sudo tasksel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.