7

I was wondering if there is a way to use the 'unity-greeter' instead of 'lightdm-gtk-greeter' for LightDM on Xubuntu Oneiric. I tried installing the unity-greeter package and changing the greeter-session entry in /etc/lightdm/lightdm.conf, but when I restart the system I get a blinking screen and the boot process get stuck.

  • I'm having exactly the same issue. – Stann Oct 29 '11 at 0:02
2

I found a solution for this.. it may work.

In my case, I installed Xubuntu 11.10 - which came with LightDM using the gtk greeter. I edited /etc/lightdm/lightdm.conf to use unity-greeter (after installing it, of course) and had the same issue.

In my case, I fixed it by installing gnome-settings-daemon from Synaptic. Seems it might be required by Unity Greeter, but isn't a dependency.

See: https://bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/850937

Hope it helps

  • That solved the problem almost perfectly. The only issue left is that the unity-greeter seems to be coded to use the Ubuntu indicators in order to display the hour, battery state and the shutdown menu, but I don't want to install them because all the dependencies. By the way, is good to know the bug is reported already. – Pablo Zubieta Nov 4 '11 at 21:09
3

Yes, this should work. Please have a look at /var/log/lightdm/lightdm.log to see why LightDM is failing to start Unity Greeter.

  • i have the same issue. and syslog says that : kernel: [ 18.799858] unity-greeter[1227]: segfault at 0 ip 00007f3ea4943b70 sp 00007fff665335e8 error 4 in libgio-2.0.so.0.3000.0[7f3ea48aa000+13b000] – Stann Oct 29 '11 at 0:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.