0

Streamlining the boot sequence for Windows 10 / Ubuntu 14 dual boot.

Ok. Ubuntu installed quite easily on my Windows 10 laptop despite the secure boot stuff. Evidently Microsoft signs Ubuntu loaders so that it is acceptable for their secure boot system. Whatever. It works.

Now I have a different problem. Firstly, I have to hit F12 at boot to see the Microsoft boot loader. Otherwise it just loads into Windows. That is not a big deal really. But it would be nice to just show the loader automatically. Not sure if anything can be done about that.

But what COULD be done is switching the order of the OS's displayed in the Microsoft loader. It loads Windows by default, so if it is not displayed (by hitting F12) it just loads windows. But if I select Ubuntu, it THEN loads the Grub2 loader, which has the selection on it for Ubuntu or Windows (with Ubuntu as the default). Seems to me that if I just set the Microsoft loader to load Ubuntu by default, I would not have to hit F12 or even SEE that loader as it would just show Grub2.

For clarity, here is my boot sequences:

Not pressing anything extra:

press power. loads Windows 10. (never shows grub2 or the windows loader)

Dual boot by Pressing F12:

press power. Displays Microsoft boot loader, showing Windows 10 as default and Ubuntu. Select Ubuntu Displays the Grub2 boot loader, showing Ubuntu as default. Select nothing, loads Ubuntu

What I propose is making Ubuntu the default in the WINDOWS boot loader, so that my new sequence would be:

Press power: (Windows loader as default selects Ubuntu, and then loads Grub 2 by default without pressing anything) Grub2 displays, I select Windows or it just loads into Ubuntu by default.

When I installed Ubuntu I just let it do things automatically. I installed it to a USB, which booted fine, ran it from USB to test it, all devices on the laptop worked, so I installed it from inside Ubuntu. I selected the automatic setup for dual boot and did not make partitions myself (other than selecting the size for Ubuntu by moving that divider bar).

Hope that is enough info. The Windows 10 version is the upgrade from Windows 8. I tried installing other versions of Linux that don't have the Microsoft approved-to-load signature and they failed every time to even get to a desktop from USB live. But of course, Ubuntu is "signed" by Microsoft to have the boot key necessary to work. The version of Ubuntu is the latest version as of this post, downloaded today. Version 14.04.3 directly from the Ubuntu website.

1

You may find solace in this link from Microsoft Answers. I take no credit for this answer:

I suggest you to boot the computer to WinRE from the elevated command prompt, and try running this command and check for the issue.

  1. Use the Windows 10 DVD to start the computer in Windows Recovery (WinRE).
  2. In WinRE, open a command prompt. To do this, follow these steps:

    • On the Install Windows screen, select the appropriate Language to install, Time and currency format, and Keyboard or input method options, and then click Next.
    • Click Repair your computer.
    • Click the 10 installation that you want to repair, and then click Next.
    • Click Command Prompt.
    • At the command prompt, type the following commands, and then press ENTER:

cd /d Partition:\Windows\System32

bcdedit /timeout 5

You may also change the timeout value to anything below 30. Now you may restart your computer and check if you are able to boot to the desktop.

Refer:

Change the default operating system for startup (multiboot)

  • @user28788 You can also run 'msconfig' and look at the options in the boot tab. – Dooley_labs Oct 6 '15 at 18:26
0

Well, I fixed the issue rather easily.

Booting, pressed F2 to get into Bios. This used to be impossible in win 8 but for some reason in win 10 this is easy.

Under the BOOT tab, I simply selected "UbuntuWDC WD10JPVX-22JC310" and move it to position 3, above "Windows Boot Manager"

Now the boot sequence bypasses the Windows Boot Manager completely and goes straight to the Grub2. Selecting Windows from Grub2 does start a rather long boot for Windows, but I don't care as I hardly ever use Windows 10. Selecting Ubuntu loads Ubuntu pretty quick.

Regarding the solution above, I did shorten the boot delay of the Windows loader but did not have to use dos instructions to do so. I just went into the advanced system startup settings and found it in the boot/recovery section. That was easy.

image

  • That's another way to do it. Windows 10 doesn't offer a UEFI Secure Boot option as strict as Windows 8's was. Basically, you're moving Windows boot loader out of the question, whereas I was still using it. – Dooley_labs Oct 6 '15 at 19:19
  • Well, the Windows boot loader is not out of the loop. It is merely ignored on the first sequence. For example, to load Windows, my computer does this: power on, load grub2, select windows, load windows boot loader, default to windows after 10 sec, load windows. This is why my boot sequence is longer now when loading Windows. It would be nice to have it just not use the Windows Boot Loader at all and to just load windows directly from Grub2. But all Grub2 is doing now is just pointing to the Windows Boot Loader when you select 'Windows.' Booting into Ubuntu is pretty fast though. – user28788 Oct 8 '15 at 4:14
  • Another thing I had to do was turn off hibernate in windows so that I could access my windows files from ubuntu. I could still access them without doing that, but only read only. Opening an admin command prompt (unlike using sudo in xterm which requires a password, windows just asks you for permission to alter itself, lol) and type "powercfg/h off." Done. Then when I rebooted, all the windows directories in all their stupidity were easily accessible just using the file manager. Considering no password was required to use an admin cmd, it really makes me question the security of Windows 10. – user28788 Oct 8 '15 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.