I just tried to upgrade Ubuntu 11.04 to 11.10, but without success.

I took a picture of what the screen are showing when i try to boot: http://ubuntuone.com/4GuUrEjhJ2Bt9xX7JnRNkt

If i use recovery mode -> resume, it works.

Normal boot without the NVIDIA driver works.

Does anyone know how to fix this? :)

(Asus p8p67, Gigabyte GeForce GTX 560 Ti SOC)

Bug report on Launchpad

Same problem posted here with log files ubuntuforum

  • what happens if you rename your xorg file? sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup – fossfreedom Oct 17 '11 at 16:42
  • Nothing happened. – Alex Oct 17 '11 at 17:07
  • 1
    I had the same problem. Had to quit Ubuntu :( Still looking for another distro... – Alejandro García Iglesias Dec 14 '11 at 19:34

Try to completely remove your nvidia drivers from your system:

sudo apt-get purge nvidia*

Remove your xorg.conf

sudo rm /etc/X11/xorg.conf

Reinstall xorg completely

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64

Re-configure Xorg

sudo dpkg-reconfigure xserver-xorg


sudo reboot

You should be greeted with lightdm, this will default everything x the same way a fresh install would.

After this you can try installing the drivers again using the 'Additional Drivers' tool in Ubuntu but if those drivers don't work you can test the latest drivers from the x-swat ppa

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

Note - if the above doesn't work - try also using the PAE kernel

sudo apt-get install linux-headers-generic-pae

(tip received by @Scott)

| improve this answer | |
  • ...That did not work :( The only difference is the driver names under "Additional Drivers". – Alex Oct 17 '11 at 17:01
  • what do you have there now? – Bruno Pereira Oct 17 '11 at 17:09
  • "nvidia_current" (was named something else before it was activated) and "NVIDIA binary Xord driver, kernel module and VDPAU libary". – Alex Oct 20 '11 at 16:19
  • and if you activate the nvidia current your system doesnt boot to graphical anymore? – Bruno Pereira Oct 20 '11 at 23:21
  • It stops when I get the picture I attached. It works if I use safe mode ... – Alex Oct 23 '11 at 2:21

I could fix this issue by
logging in at tty1, purging nvidia,
logging in again at tty1 (killing the graphical interface at tty7 if needed), and installing a previously downloaded drive (from nvidia official suite).

| improve this answer | |
  • there is clearly so much I don't know... what is the difference btw TTY1 and 7 for example? – Ritwik Bose Dec 29 '11 at 11:12
  • tty1 tty2 tty3 ... tty7 are the terminals that you can access when you press Ctrl + Alt + F1 or Ctrl + Alt + F2 or Ctrl + Alt + F3 etc. The tty7 is the terminal that loads the graphical interface by default in Ubuntu. – desgua Dec 29 '11 at 19:01

In my case the problem was solved with the aid of this blog:


I know this was for 10.04 but it applies to 11.10 as well. I am quoting:

Obviously the kernel tried to allocate memory but somehow wasn't able to do so. The error manifested itself in freezing the system during start-up. As you can see in the kernel.log the boot process froze shortly after loading the bootsplash ...

Here's the solution:

Simply add more memory ^^

First of all, Ubuntu 11.04 utilizes grub2, so you won't find any "menu.lst". You could edit the "/boot/grub/grub.cfg" but this file gets overwritten every time you update your kernel (e.g.). So find "/etc/default/grub" and edit the line "GRUB_CMDLINE_LINUX_DEFAULT". Now, add the option:


GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vmalloc=192MB"

sudo update-grub

Now Natty boots like a charm, no freezing, if 192MB aren't enough -- try to increase the value. Hope that helps.

| improve this answer | |
  • I tried twice, first with 192MB then 512MB, it did not work. I can not find the error messages that are on the page you link to, so it is something else. :'( – Alex Oct 23 '11 at 2:25

Which nvidia graphics card are you using? In case if you are using nvidia with optimus you have to install ironhide or bumblebee, normal procedure doesn't work if its a case of optimus. Refer the following link


Its for dell xps but it should work for all optimus supported models

| improve this answer | |

Same problem here. After a fresh install of Ubuntu 11.10 the graphical environment will never load. What worked for me(sort of) was:

1) On the grub menu I chose "Previous Linux Versions". (This boots me with 3.0.0-12-generic instead of 3.0.0-12-generic-pae)

2) This time Unity loads. I go to 'System Settings' -> 'Additional Drivers' , and choose some other option. I restart.

3)Now Ubuntu loads throughly on standard more, with 3.0.0-12-generic-pae, but I lost dual-screen mode. Only one monitor gets recognized. I go to 'Additional Drivers' and see that my driver option wasn't activated(I tried them all, none gets activated except for the initial "version 173"). It seems Ubuntu falls back on something other than the proprietary driver and so it works.


It would have been a happy ending if I used only one screen. But I'm still unhappy for I have no dual-mode screen.

I might try brunopereira81's approach next.

| improve this answer | |
  • It was the first thing I tried but it did not work. = / – Alex Oct 23 '11 at 2:19

Same problem when I try to activate my NVidia driver. I'm not sure, but it might be related to NVidia's "Optimus" technology...

When you boot and there is no guy, you can do CTRL+ALT+F2 to switch to the command-line. Once there (login with your user name/pass), you could try to restore the default xorg contents:

  1. sudo -s
  2. cd /etc/X11
  3. mv xorg.conf xorg.conf.backup
  4. echo -ne "Section \"Device\"\n\tIdentifier\t\"Default Device\"\n\tOption\t\"NoLogo\"\t\"True\"\nEndSection" >> xorg.conf
  5. restart -r now

This probably isn't the best permanent solution, but at least it should get your desktop running again. Worked for me after the nvidia driver modified my xorg.conf and prevented X from starting.

| improve this answer | |
  • 1
    So you remove your xorg.conf and then tell it to not do much? removing the xorg.conf file would have the same result... – Bruno Pereira Oct 23 '11 at 3:05
  • I backup the existing xorg.conf and create a new one with the default content. The original xorg.conf had nvidia stuff in it, which I had to get rid of. This should load the default driver instead of the nvidia one. Worked for me: now I have a crappy, slow, poor, buggy driver. But I have a driver and a desktop with gfx acceleration. – Eti Jan 21 '12 at 11:02
  • Those options will not do anything except not load a logo that will not be loaded on the first place because the driver is not even loaded on xorg.conf. – Bruno Pereira Jan 21 '12 at 11:24
  • Well it did make Xorg load again. You see, I don't really care what exactly happens behind the scene when I can get Xorg to load again after a day without Xorg. It's not like I have entire days of free time to fix such issues. Without that modification, I would not be writing here right now... – Eti Jan 21 '12 at 12:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.