4

I run my computer on Ubuntu 14.05 LTS and have recently connected a new HP Color LaserJet MFP-M277dw. The connection is local via USB.

At the point of first usage, the system did recognize the device somehow so that I could print, but I cannot scan documents yet. Full scanning functionalities are the aim.

From https://help.ubuntu.com/community/HpAllInOne I learn that

You have selected Ubuntu 14.04 using the HP Color LaserJet MFP m277dw. Ubuntu 14.04 supplies HPLIP 3.11.5 by default, which does not support your printer. You must ensure latest HPLIP version (recommemded), or at least HPLIP 3.15.4 in order to use your printer with Ubuntu 14.04.

Checking on http://packages.ubuntu.com/search?keywords=HPLIP&searchon=names&suite=trusty&section=all shows that, to date, Ubuntu 14.04 covers up to HPLIP 3.14.3 only.

The question is: what is the fail-safe strategy (i.e. the sequence of commands) that I should follow to get this all-in-one printer to scan?

I have run hp-check -r whose output is here.

Thanks for dealing with this.

  • Assuming that you do not want to update your version of Ubuntu, you will need to install a newer version of HPLIP. This can be done using the HP Installation Wizard – Charles Green Oct 6 '15 at 15:24
  • See also hplipopensource.com/hplip-web/models/color_laserjet/… . To scan you will need SANE installed, and a program like Simple Scan, XSane, hp-scan (with hplip) to scan with – Wilf Oct 6 '15 at 15:42
  • Failure report. a As I proceed with the HP Installation Wizard and force installing HPLIP 3.15.4 on Ubuntu 14.04, it proceeds smoothly until it asks permission to remove the existing HPLIP version (proceed or quit). b Then it fails with configure: error: cannot find python-devel support: screen output here. c The whole of HPLIP has been uninstalled though, since typing hp-check -r yields a currently-not-installed notification. d If I try to print a test page, no print job moves on, expectedly at this point. – XavierStuvw Oct 6 '15 at 15:59
  • Additional information. I have reinstalled hplip. The printer appears to be connected but. when I send a print task, the job is queued and stopped. It takes the status 'stopped' also if I ask to retrieve the task. Quite the contrary of a fail-safe approach. Has anybody tips to sort this out please? – XavierStuvw Oct 10 '15 at 10:01
  • Additional information 2. I tried to uninstall and install the printer. Then the model is not recognized by the installation wizard. This is expected based on the text quoted above, but in contradiction with the link given by Wilf. I then select the recommended alternative (HP Color Laser Jet M855) and the test page fails in the same way as above: it gets in the queue but hangs on hold with status 'Stopped'. Thus this is a stubborn issue. – XavierStuvw Oct 10 '15 at 10:21
2

My research is shared in the comments below the question post. In essence I came across two barriers:

  • Nominally, the minimum HPLIP version needed for this new printer model is not supported by the Ubuntu standard toolkit. This is not a hard limitation though. I could install the latest HPLIP version 3.16.11 (so this answer has been updated, dated Feb 2017) while holding on to Ubuntu 14.04.

    • I went to http://hplipopensource.com/hplip-web/gethplip.html to download the installer hplip-3.16.1.run in a convenient directory. This is a bash script and you may need to make it executable (say chmod 774 hplip-3.16.1.run). It starts a interactive build of hplip.
    • The interactive dialogues launched by the script are described pretty well in http://hplipopensource.com/hplip-web/install/install/index.html. It recognizes missing dependencies and installs them --- in my situation this caused no critical situation such disruptive or avalanching dependencies requests. It also took care patiently of removing the extant version 3.14.3.
    • Then, the script gave the option to run the tools hp-setup and hp-plugin. They took care of identifying the printer model, install the relevant PPD file (driver) and customize some settings such as the device names for printer and fax.
    • In the end I have printed out the test page successfully. The scanner is active (type 'scan' in the Launcher). I have not tested the fax.
    • As a last step, at the point of printing a document from an application (say, gedit), there was a claim that the printer was not connected whereas it was. To fix this, I went to the CUSP interface page http://localhost:631/admin and added the printer manually following the instructions displayed there. Hence the printer showed up in the tab http://localhost:631/printers. At this point, the printing queue moved on, much to my relief.
  • The earlier upgrade process to HPLIP 3.15.4 in another computer was not fail-safe. A missing library python-dev interrupted the installation of the latest version, but the script did not fall back onto the earlier version that had been wiped out in the meantime. Nowadays the installation script for 3.16.11 takes care of dependency and conflict issues. However, for one computer out of four (all Ubuntu's 14.04), the bulk of HPLIP got installed while some important utilities, such as hp-setup and hp-plugin, failed. This problem is detailed in another post on SuperUser

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.