6

I have recently noticed that in Libre Office Writer 5 (that I installed from here), no matter what I type, I don't get the red underlining (or any underlining) for words that do not exist. This does not happen in other programs, and I have tried going Tools > Spelling and Grammar and it still thinks that all spelling is correct, even when I type in words such as:

sdfioeurtoiuertioeurtgjh

This also did not happen with previous versions of Libre Office Writer. So why could this be? Is this a bug? Or something that I can fix?

Information Update:

This is what my language settings for it are:

enter image description here

enter image description here

And the output of dpkg -l | grep hunspell is:

ii  hunspell-en-us                                              20070829-6ubuntu2                          all          English_american dictionary for hunspell
ii  libhunspell-1.3-0:amd64                                     1.3.3-3                                    amd64        spell checker and morphological analyzer (shared library)

OS Information:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:    15.04
Codename:   vivid
Flavour: GNOME
GNOME Version: 3.16

Package Information:

libreoffice-writer:
  Installed: 1:5.0.2~rc2-0ubuntu1~vivid2
  Candidate: 1:5.0.2~rc2-0ubuntu1~vivid2
  Version table:
 *** 1:5.0.2~rc2-0ubuntu1~vivid2 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status
     1:4.4.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
  • Did you try to reset your LO user profile? – tohuwawohu Oct 6 '15 at 15:02
5

First, select an installed language for Default Languages for Documents. Installed languages have an little icon in front of the name as you can see in my screenshot.

enter image description here


Second, install your missing language English (UK) via

sudo apt-get install libreoffice-l10n-en-gb

or via the Language Support

  • Install via

    sudo apt-get install language-selector-gnome
    
  • Open Language Support and all missing libraries will be installed automatically

  • 1
    For me it turned out that not only the LibreOffice language packs were not installed, but also some Ubuntu language packs were not fully installed. So after installing the LibreOffice language packs I opened the Ubuntu Language Support (which can be found under Applications -> System Tools -> System Settings ==> Personal -> Language Support). There it complained about the missing packages and offered to install them. Now spell checking works. Thank you! – Jenny O'Reilly Jan 2 '17 at 11:06
  • My spellcheck was working fine but one day it stopped and I couldn't figure out why. Now I know that it was because I changed the language from EN(US) to EN(CA), but I don't have Canadian English installed on my system. Thanks for the help, works great now :) – cheesits456 Mar 10 '17 at 23:45
2

I found that going to "System Settings" > Language support launched a dialogue telling me that some packages weren't installed and asking me if I wanted to install them now. I did so, restarted Libreoffice writer and spell check on the fly was working.

0

If you use the search function in the top of the launcher and just type in ubuntu language you should see what looks like a UN flag, click on that should get you to your destination to install the languages that are not installed properly yet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy