1

The overall target of the setup is a lab system based on a single server. To get familiar with Ubuntu MAAS, Juju and Openstack my goal is to "simulate" physical servers to be controlled/managed by MAAS.

The host system OS is Ubuntu server 14.04.3 LTS release and should host a MAAS controller (mass-controller-vm) and "physical" servers (vm1 - vm8).

enter image description here

For the "mass-network" I have created a virtual bridge (virbr1) with connectivity outside the system via NAT. The MAAS controller managed interface is connected via eth1 (172.16.0.200) to virbr1. To reach the MAAS GUI from remote, I have created an interface (eth0 10.49.228.163) to br0.

The initial setup of the VM's (vm1 - vm8) is done via remote VMM.

The MAAS controller eth1 interface is configured according MAAS documentation. The only point where I have an issue is regarding the MAAS cluster managed interface configuration (eth1). When I configure under the "edit cluster interface" the "router IP" = 172.16.0.1 than the "physical" server PXE boot process will not finish successfully. The next two screenshot showing the last state: enter image description here Followed by following error messages: enter image description here

When I configure under the "edit cluster interface" the "router IP" = 172.16.0.200 than the "physical" server PXE boot process will finish succesful but the default gateway on the "physical" server (e.g. vm1) is 172.16.0.200 which is indeed wrong for the 172.16.0.0 subnet.

Routing table on MAAS controller:

c220@maas-controller:~$ route -n Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 10.49.228.170 0.0.0.0 UG 0 0 0 eth0 10.49.228.160 0.0.0.0 255.255.255.224 U 0 0 0 eth0 172.16.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1 192.168.122.0 0.0.0.0 255.255.255.0 U 0 0 0 virbr0 c220@maas-controller:~$

What's going wrong here? The ethe0 interface on the MAAS controller vm is declared as an unmanned interface under "edit cluster controller" page.

Any help/ideas are welcome.

Frank

  • Your error message indicates [host=169.254.169.254]. I don't see this network anywhere it your setup. It sounds like the sort of made-up address my MacBook would issue if it couldn't find a DHCP server. I'm guessing that the cluster controller's default gateway should point to the upstream IP address toward the Internet. And then the default gateway for that 172.x.x.x network should be that 172.x.x.200 address to move things in the correct direction. – Michael Blankenship Oct 7 '15 at 17:29
0

I just ran into this same problem. I disabled the second interface on my MAAS server and I'm attempting an openstack-install now. Once the second interface was gone, I had no issues using my cisco as default route rather than the MAAS server.

0

I've resolved that in this way, but I dont know if that one is correct. My network configuration file is so configurated:

# The loopback network interface
auto lo
iface lo inet loopback

# The Management network interface
auto eth0
iface eth0 inet static
 address 1.1.100.10
 netmask 255.255.255.0
 network 1.1.100.0
 broadcast 1.1.100.255
 gateway 1.1.100.1
 # dns-* options are implemented by the resolvconf package, if installed
 dns-nameservers 1.1.100.10
 dns-search maas

# The Private network interface
auto eth1
iface eth1 inet static
 address 1.1.101.10
 netmask 255.255.255.0
 network 1.1.101.0
 broadcast 1.1.101.255
# Ubuntu Linux add persistent route command ###
 post-up route add -net 1.1.101.0 netmask 255.255.255.0 gw 1.1.101.254

in this way my private nodes can use its own gateway

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.