3

I'm using Ubuntu 14.04 on a Mac and use Eclipse and EiffelStudio for programming. My keyboard layout is set to "German (Switzerland, Macintosh)" which I would like to keep because I'm familiar with the shortcuts of this layout. My problem is that I am sometimes getting the compilation error

    stray '\240' in program
    stray '\302' in program

which happens after I accidentally pressed SHIFT+Space (instead of Space only). This produces a no-break space which can not be interpreted. Removing this space and adding one again solves the problem, but this becomes tedious after some time. I tried the keyboard layout "German (Macintosh, eliminate dead keys)" where I did not have the problem, but I would actually prefer to work with my current keyboard layout.

Where can I adjust my current keyboard layout settings such that SHIFT+space does not result in a no-break space but just a normal space instead?

1

I found the answer on this site: https://help.ubuntu.com/community/AppleKeyboard (point "Disabling non-breaking space"). In the ~/.Xmodmap file, I had to change keycode 65 to

keycode 65 = space space

and after applying the changes with

xmodmap ~/.Xmodmap

it worked as i wanted (I had also to put this last command into my .bashrc file to make the changes permanent).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.