When I try and install the RTL8188CUS drivers downloaded from Realtek (using their install.sh shell script) I installed the drivers in 11.04 using individual commands to make, etc., and that worked OK, but using individual commands now gives the same error. What's changed in 11.10????

sudo bash install.sh

...all goes well until an error message appears

Authentication requested [root] for make driver: make ARCH=i386
CROSS_COMPILE= -C /lib/modules/3.0.0-12-generic/build
modules make[1]: Entering directory
`/usr/src/linux-headers-3.0.0-12-generic'   CC [M] 
In file included from
fatal error: linux/smp_lock.h: No such file or directory compilation
terminated. make[2]: ***
Error 1 make[1]: ***
[_module_/home/karl/rtl8188cus/driver/rtl8192_8188CU_linux_v3.1.2590.20110922] Error 2 make[1]: Leaving directory
`/usr/src/linux-headers-3.0.0-12-generic' make: *** [modules] Error 2
Compile make driver error: 2, Please check error Mesg

Thanks, fossfreedom, for your attention.

I did a completely fresh install of Ubuntu 11.10. I then followed the troubleshooting pages for wireless networking and found that the realtek rtl8192cu driver was in the library, and used modprob (I think) to enable it as directed. It is associated with the realtek usb adaptor in Network Manager, and one can see the available wireless networks (so I know its working to some extent). When I attempt to connect to my wifi network, it prompts for the WEP code and tries and tries to connect. When it times out, it prompts for the code again.

I have stuck in an old Broadcom usb dongle, which connects happily using the WEP code.

So, my current guess is that it is a driver problem. Do I report a bug to Ubuntu, as it is part of the delivered ver 11.10? Or to Realtek?

Thanks for your reply, fossfreedom

I tried using uppercase for the WEP passphrase and also for the HEX WEP code, to no effect.

I have tried disablng WEP encryption on the router, and still the old Buffalo connects and the Realtek fails to connect... it seems slow also in recognising that the network is unencrypted (doesn't have the padlock on the little icon.

I will see about posting a bug with Ubuntu: I've asked the manufacturer to check with Realtek.

Any further advice welcomed.

  • I'm a little surprised that this isnt already in the kernel - can you confirm? sudo lshw -class network – fossfreedom Oct 17 '11 at 16:40
  • Sometimes you may have your router wireless channel number set incorrectly - some cards are more sensitive than others. If you type dmesg just after connecting via network-manager then there should be errors displayed as to why the connection failed. – fossfreedom Oct 19 '11 at 22:32
  • ... as to your build issues - have you install the correct linux headers for your kernel. You have remembered to install build-essential as well? – fossfreedom Oct 19 '11 at 22:34

to solve the "linux/smp_lock.h not found" error you need to edit this two files into the archive driver/rtl8192_8188CU_linux_v3.1.2590.20110922.tar.gz

file 1: include/rtw_io.h

Change osdep_service.h (line 49) linux/smp_lock.h to linux/smp.h

file 2: include/osdep_service.h

Change file rtw_io.h (line 36) linux/smp_lock.h to linux/smp.h

| improve this answer | |
  • 1
    +1000, it's a pity I can't upvote you further. I can confirm this is also applicable to the RTL8192CU driver. You saved my 11.10 install. I was thinking in going back to 11.04 just to be able to install this driver again. – Xavi López Nov 8 '11 at 19:50
  • Had this problem while compiling alsa. I don't know why there's a discrepancy in these two filenames but I created a symlink to smp_lock.h from smp.h and it works. Thanks! – lfzawacki Mar 19 '13 at 0:48

blacklist rtl8192cu as well, it is the default driver, this will make the system use the new one.

| improve this answer | |
  • Could anyone please explain how to do this? – Tal Galili Nov 17 '11 at 8:49

I wrote a post that combined all of the solutions proposed here


chiicoff, icracked - you two saved my day.

(p.s: the line numbers should be reversed)

| improve this answer | |
  • thank you for the effort! It was nice to have all things gathered in logical order - one thing had to restart :) – deckoff Feb 29 '12 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.