0

I am running g++ 4.9.2.0ubuntu1~14.04 (installed from the toolchain ppa: ppa:ubuntu-toolchain-r/test), and I want to use the Virtual Table Verification (VTV) feature (-fvtable-verify in C++ dialect options). When I run the command:

g++ -fvtable-verify=std -o test test.cpp

The linker exits with the following errors:

/usr/bin/ld: cannot find vtv_start.o: No such file or directory
/usr/bin/ld: cannot find -lvtv

The same error occurs with g++ 5.1. Any clue what might be wrong? Should I install any additional packages for the VTV to work?

Update. Trying to manually install libvtv using apt-get install libvtv0 fails with the following error:

The following packages have unmet dependencies:
libvtv0 : Depends: gcc-4.9-base (= 4.9-20140406-1ubuntu1) but 4.9.2-0ubuntu1~14.04 is to be installed
0

Recompiling gcc from source with --enable-vtable-verify solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.