0

I have ubuntu 14.04 installed on my system and everything worked fine until I tried to install a graphics card (nvidia gt 630). I put the graphics card in the computer and plugged the monitor into the card and there was no input. The monitor recognized that it was plugged in but was receiving no input. Then I plugged the monitor into the port for the on board graphics and the system was running in low graphics mode. I've tried installing the nvidia drivers multiple times and still cannot get anything to show in the additional drivers menu.

I tried installing the driver with:

sudo apt-get install nvidia-304-updates

The problem seems to be that the driver isn't being installed and I don't have the standard driver that usually comes with ubuntu. The only graphics driver I see on the list there is the Intel one.

output of lspci -k | grep -EA2 'VGA|3D' is

00:02.0 VGA compatable controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09) 
    Subsystem: Dell Device 0581 
    Kernel driver in use: i915 

output of lspci is

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.5 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 6 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a4)
00:1f.0 ISA bridge: Intel Corporation B75 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)
  • 1
    Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command. And how and which drivers do you install? – Pilot6 Oct 5 '15 at 22:50
  • Please read my comment again carefully. – Pilot6 Oct 5 '15 at 23:16
  • I do not see any Nvidia adapter there. Please add also output of lspci. – Pilot6 Oct 5 '15 at 23:36
  • There is no Nvidia adapter, or it is disabled in bios. – Pilot6 Oct 14 '15 at 21:47
  • How would I check if its disabled in the bios and if it is how do I enable it – KoalaStorm Oct 16 '15 at 17:05
0

First of all nvidia-304-updates is a wrong driver for your card. Install the correct one this way

sudo apt-get purge nvidia*
sudo apt-get install nvidia-346

and reboot. If the adapter still is not detected, try this solution.

  • I dont seem to have an etc\X11\xorg.conf file that is mentioned in that solution and I am being denied the ability to make one. The closest thing is etc\X11\xorg.conf.failsafe which appears to be required to revert to on board graphics in case something goes wrong. – KoalaStorm Oct 18 '15 at 7:23
  • You can create this file. But in Ubuntu it is located at /usr/share/X11. In /etc/X11 it will work as well. – Pilot6 Oct 18 '15 at 8:10
  • whenever I try to create the file or move the file into that folder it is saying permission denied because root is the owner of the folder – KoalaStorm Oct 18 '15 at 9:47
  • askubuntu.com/questions/92379/… – Pilot6 Oct 18 '15 at 10:01
  • I got that file set up and rebooted the computer but it still has the same problem – KoalaStorm Oct 18 '15 at 10:10
0

Didn't work after install and reboot for me, until I turned off Intel graphics acceleration in BIOS. Apparently that option conflicts if you just use a dedicated Nvidia card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.