8

So I just installed Ubuntu for the first time last night, so I qualify as an uber-Ubuntu noob. Anyway, the Alt-Tab switcher in unity, it just shows icons. At first I didn't think anything of it, until I saw some screenshots from someone else's machine that showed full window thumbnails.

To clarify, when I press Alt-Tab, I see a collection of icons for the various programs that I have open. If I hover over a program where I have multiple windows open, say the web browser, the view changes and it shows thumbnail images of what the windows currently look like.

Online, I've seen someone have an Alt-Tab switcher in unity that shows a window thumbnail for all open windows. This looks way nicer than the icon view, and coming from Windows I would prefer it. I just don't know how to make it that way.

I've used unity tweaks and compizconfig, but I haven't been able to get it to work. Any suggestions?

  • 1
    When in ALT-TAB press the down key on your keyboard, to preview the app. And to preview all the app open, press the super(windows) key on your keyboard with w. super-W. – blade19899 Oct 5 '15 at 16:13
  • 1
    That's not what he asked. I've seen videos too where the preview images of windows are the default, instead of the icons. Is there a way to do this? – user2223059 Mar 2 '16 at 22:46
11

I accidentally stumbled on this workaround:

When ALT-TAB does not display icons of running applications, use super-d which will show your desktop.

Now try ALT-TAB and you should see the icons.

The problem re-appears soon, so I have to repeat the super-d pretty often. A tiny bit annoying I prefer it to rebooting.

  • Super+D no longer seems to work in Unity 7.4.0. – Dan Dascalescu Sep 4 '16 at 10:08
  • 4
    Now it's Ctrl+Super+D – Maidomax Sep 7 '16 at 20:00
5
  1. Install Compiz Config Settings Manager and the compiz-plugins-extra:

    sudo apt-get install compizconfig-settings-manager compiz-plugins-extra

  2. Start Compiz Config Settings Manager and disable the Ubuntu Unity Switcher like this: Search for the Ubuntu Unity plugin in the top left corner.

Select the switcher tab and disable everything.
Note: If you don’t disable all the features then you'll have conflicts.

  1. Enable the old Compiz Switcher:

Search for the application switcher in the top left corner. Finally Enable the Applcation Switcher.

  • Not the best explanation imho but I found it in the end ^^ – displayname Dec 18 '17 at 11:07
2

As of Ubuntu 16.04.1, one workaround is to press Super+W. This will show what KDE calls a "grid" of the windows in the current workspace. Shift+Super+W will "spread" all the windows in all workspaces.

Unity windows spread

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.