0

These days my ubuntu is done again and this time i even cannot fix via external USB by boot repair tool. Even the first command:

ubuntu@ubuntu:~$ sudo chroot "/mnt/boot-sav/mapper/isw_cdfdjdhbjc_TF0501WJGPL46R5" dpkg --configure -a Setting up fontconfig (2.11.1-0ubuntu6) ... Regenerating fonts cache... failed. See /var/log/fontconfig.log for more information. dpkg: error processing package fontconfig (--configure): subprocess installed post-installation script returned error exit status 1 Errors were encountered while processing: fontconfig

This is the summary via boot repair. http://paste.ubuntu.com/12689827/

Now the situation is that i will directly enter the grub command mode, i also try

set prefix=(hd0,gpt5)/boot/grub
set root=(hd0,gpt5)
insmod linux
linux (hd0,gpt5)/vmlinuz root=/dev/sdbx ro #i cannot find any related sub-dir in dev directory actually

I can still enter my win8.1 by typing exit to exit the grub but i cannot enter my ubuntu. Do anyone have similar situation or any solution? Thanks a lot!

0

Basically, you've done what I did to my external Ubuntu installation when messing with dpkg. It looks like you may have deleted the kernel, to which the only fast fix is to backup your /home directory and reinstall ubuntu. This is what I've done to fix it, as boot-repair does not have a copy of the proper linux-kernel on it.

I hope this helps!

  • I also tried command like this: linux (hd0,gpt5)/boot/vmlinuz-2.6.xx-xx-generic. I think it is the kernels that i have, but i have several, and i tried two, they cannot work either. So i am not sure whether i have deleted the kernel. – Alex Oct 5 '15 at 21:40
  • After a few trials, i think the kernel was broken or something. There are ways to re-install the image only, i tried. But it does not fit in my case. In the end i re-install the whole system. – Alex Oct 8 '15 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.