Possible Duplicate:
Delete extra toolbar on top of the screen in GNOME fallback mode?

After getting gnome working and the panels moved back to the bottom where it's finally usable again, and where I prefer them, the Mac-style File/edit/view/.. menu remains on top. I've tried the sudo apt-get remove indicator-appmenu appmenu-gtk and removing the dbus menu applet and the annoyance remains. Any clues?


To remove the global menu run sudo apt-get remove appmenu-gtk3 appmenu-gtk appmenu-qt in a terminal. You will need to restart your computer before the change takes effect.

| improve this answer | |
  • 1
    Fantastic, that worked!! Thank you. Now if I can get apps to show up on the task bar and cut/paste to work again into an xterm window I'll be as functional as I was before an "upgrade" to 11.10. – Argyle Oct 17 '11 at 16:04
  • 1
    @Argyle if you consider this answer fixes your issue it would be nice you marking it has answered so future users experiencing the same issue easily find an answer to their problem. – danjjl Oct 17 '11 at 16:12

Adding the previous 'behaviour' is a better option than removing Unity. In order to do that:

  1. Open shell and run:

    sudo apt-get install gnome-shell

  2. Once installed, you have to reboot.

  3. After the reboot, on the login window select Gnome classic

The good thing about this, is that you can go back to Unity any time you want, simply log out and select Ubuntu on the login window (step 3).

| improve this answer | |
  • Thanks for the response. However, I did that to get gnome in the first place, not having that as an install option was a very unfortunate decision. It takes hours of fiddling to get somewhere close to semblance of usability. "unity" has to be one of the worst "forced" interfaces I have seen. – Argyle Oct 17 '11 at 16:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.