6

Previously I had Dell Inspiron Laptop with Legacy Boot and MBR disk partitioning with pre-installed Ubuntu 12.04. I needed dual boot with Windows. So I formatted it completely using Live USB, installed new Windows 8.1 and then installed Ubuntu 14.04, each of Windows and Ubuntu in Legacy mode. When I used to start my laptop, after exiting BIOS it shows GRUB menu where I can choose from Ubuntu or Windows 8.1 options.

Now I have HP Pavilion 15 Laptop which has pre-installed windows 8.1 in UEFI mode and GPT disk partitioning. I installed Ubuntu 14.04 alongside on it and everything is working fine except that I had to pres Esc key as soon as the laptop starts and then pressing F9 - Boot Device Options and then selecting Ubuntu from the menu that appeared. If I don't press F9 it'll directly boot to windows. And no GRUB menu is shown.
Can someone help me how can I get GRUB menu on it?

  • 1
    Sounds like you installed Ubuntu in CSM/BIOS/Legacy boot mode not UEFI. UEFI & CSM are not compatible, and you can only select to boot from UEFI or one time boot key, not grub menu. Or grub can only boot systems installed in same boot mode. Also HP is not UEFI boot of Ubuntu friendly. It only boots Windows, but we have work arounds: askubuntu.com/questions/486752/… and: askubuntu.com/questions/597052/… – oldfred Oct 4 '15 at 15:25
3

First try to change the boot order in BIOS (UEFI) settings.
Select Ubuntu to be the default operating system to boot.

If this is not possible boot into Windows and disable hibernation and Fast Boot.

To disable hibernation open command prompt as administrator and execute this command:

powercfg /h off  

To disable Fast Boot open Control Panel (the old version - not the modern design),
select the Energy Settings, enable show hidden settings and uncheck Fast Boot.

After having done this shutdown the machine completely - do NOT reboot!

Then reinstall the GRUB boot loader to your Ubuntu installation in EFI mode.

Boot from the Ubuntu installation media - then open a terminal and execute:

sudo mount /dev/sd*** /mnt
sudo mount /dev/sd** /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
sudo chroot /mnt
grub-install /dev/sd*
update-grub  

Now you can choose which operating system you want to boot from the GRUB boot loader menu.

Note :

sd* = disk | sd** = efi partition | sd*** = system partition

To identify the partition numbers use GParted.
The tool is included in the Ubuntu install media.

2

get in to UEFI setup and change the UEFI boot order. enter image description here

you will see a entry like " OS boot Manager" make it the first entry of the list and save changes. now it will directly boot in to grub!

  • 2
    This is not possible, since "ubuntu *" does not show up. Only OS boot Manager. – Timm Simpkins Aug 9 '17 at 18:07
2

This applies to most Acer models (Problems generally faced with Predator and other gaming laptops):

For normal Ubuntu installation:

  1. Update to the latest BIOS (I know, it's UEFI, but I'm going to call it a BIOS).

  2. Shut down, then while starting back up hit the F2 button many times until the BIOS Setup Utility loads.

  3. In the "Main" menu, set the "F12 Boot Menu" option to "Enabled". Press F10 to Save and Exit, then once Windows loads shut down again.

  4. Insert your USB flash drive with your 64-bit Ubuntu installer on it.

  5. Power on and keep pressing F12 until the boot menu pops up. Select the flash drive, boot, and install Ubuntu.

This is where things get tricky

  1. After Ubuntu reboots, it will boot back into Windows. Shut down again. Reboot and hit F2 to enter the BIOS again.

  2. Under "Security", choose "Set Supervisor Password", and set one. You will need this password any time you go back into the BIOS. A bunch of options on the page should change from grey to blue.

  3. The "Select a UEFI file as trusted for executing" should now be available. If it's not available, check that Secure Boot is still enabled, if not, enable it. Select it, and navigate to HDD0->EFI->ubuntu->grubx64.efi. The BIOS will ask you for a name for it, I called it Grub.

  4. Hit F10 to save and exit, then immediately hit F2 again to re-enter the BIOS.

  5. Now go to "Boot", set "Secure Boot" to "Disabled", and arrow down to the bottom of the list to your new "Grub" entry. Hit F6 until it's the top of the list.

  6. Hit F10 one last time. Your system should now reboot to the Grub boot loader!

Credits- [HOW-TO] Dual boot Acer Aspire R14 - Ubuntu Forums

0

I have HP 11 laptop and also have the same issue. Everytime it loads HP logo and then Windows 10. The easiest is press Esc at startup, or press F9 to directly select OS startup. I can choose windows or ubuntu. Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy