5

I've tried Chromium, Chrome, and Firefox. I've tried various flash players (including Adobe Flash). I'm logged in through my cable provide. Still, no dice. I see some very old posts about installing "hal", but hal doesn't exist as a package any more, it seems.

6

They require Adobe's Hardware Abstraction Layer (HAL) to be installed to view secured content (i.e DRM encumbered). The solution to install HAL is:

sudo add-apt-repository ppa:mjblenner/ppa-hal
sudo apt-get update
sudo apt-get install hal

Source: http://ubuntuforums.org/showthread.php?t=2255621

More information can be found here:

https://launchpad.net/~mjblenner/+archive/ubuntu/ppa-hal

A few are still complaining it isn't working while others state that it works for them and that it works for other sites that they had previous issues with. Make sure to follow the directions carefully - if you have any questions then feel free to ask. Ensure that you have ad blocking software or script blocking software disabled for the site in question as well. If this resolves your problem then please be sure to mark it as solved to let others better find the solution.

Edit: I forgot to mention that the project appears to still be active but doesn't have a lot of resources. Their most recent package was July 3rd of this year.

  • Still not working. Ubuntu 15.10. Chrome and Firefox. – Dustin Kirkland Oct 24 '15 at 22:34
  • @DustinKirkland As 15.10 is still very new there may be a conflict which will require the HAL package to be updated. What I can suggest is adding the PPA and hopefully a package will drop soon. Are you using any third party add-ons with your browser? Hulu is, for instance, pretty specific with what works and what doesn't. – KGIII Oct 24 '15 at 23:37
  • Worked for me on Kubuntu 15.10, but it was buggy and had to sign in and out several times before it worked. – r3wt Apr 24 '16 at 0:35
1

The instructions about installing HAL and using flashplugin-installer worked for me on one computer (in 15.10), but not on another (also in 15.10). After deleting ~/.mozilla/ a few times, I finally came upon this arch wiki entry about Flash DRM which mentioned that the Adobe flash plugin keeps a cache of files that may cause some trouble. It suggests:

rm -rf ~/.adobe/Flash_Player/{NativeCache,AssetCache,APSPrivateData2}

I was a bit less careful and just removed the entire ~/.adobe/ directory, at which point I was able to get espn3 working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.