1

I'm using the program xtrkcad to design a model railroad layout. The version 4.2.1 has been out for several months, and I'm using it. But whenever I do an update, the system updater wants to install an older version (4.0.2). What does it take to get the newer version into the repositories so that it will be installed (or more precisely, so the older version won't be installed, overwriting the newer version)? I'm just a user, not the maintainer of this software.

0

currentUbuntu version not support latest version 4.2.1 of xtrkcad. it support 4.0.2 even wily version not support version more than 4.0.2. so there is only option to install it manually. see here.

uninstall older version of xtrkcad if you are already installed using command

sudo apt-get purge xtrkcad

and download latest version 4.2.1 from here according to your system architecture. then install using command:

sudo dpkg -i xtrkcad_4.2.0-1_amd64.deb

if this show any dependency error then run command:

sudo apt-get install -f

it will install dependencies of xtrkcad then again install

sudo dpkg -i xtrkcad_4.2.0-1_amd64.deb

or

you can download source code from here and compile manually .

EDIT : if you don't want to upgrade or downgrade any package then you can put that package on hold using command :

echo "xtrkcad hold" | sudo dpkg --set-selections

or

sudo aptitude hold xtrkcad

or

sudo apt-mark hold xtrkcad

or use Synaptic Package Manager to lock version

or try other solution suggested in How to prevent updating of a specific package?

and also see What does 'Lock Version' do? . these are popular question but old so it may be some solution may not work but this is good.

|improve this answer|||||
  • I already have the new version installed and working. My problem is how to avoid having the old version brought back and reinstalled when I do a normal update. That's why I think that someone has to do something about the repositories themselves. I've been able to work around the problem by modifying the update whenever I do it, but that's not a very good solution. – Paul A. Oct 4 '15 at 4:33
  • ubuntu not support latest version . it support 4.0.2. even wily version not support version more than 4.0.2. so, there is no option other than manual installation . see packages.ubuntu.com/… – pl_rock Oct 4 '15 at 4:42
  • Version 4.2.1 runs just fine under Kubuntu 14.04. How could that be true if it wasn't supported? My problem is that a general update of my system causes the xtrkcad version to revert to 4.0.2, so I have to explicitly block just that program from being updated. – Paul A. Oct 6 '15 at 1:33
  • @user101815 support not mean it will not work it means it not providing support of particular version . may be they include this version in next release. you can install manually . also check i have added solution . i hope it will help you. – pl_rock Oct 6 '15 at 2:27
  • I've solved the problem for myself using//sudo aptitude hold xtrkcad. But what does it take to get the correct version into the official repositories so that the problem can be solved for everyone else? – Paul A. Oct 31 '15 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.