3

Installing Server 14.04 and configuring software RAID-1. I already made my swap partition on my first HDD, and when i configure the remaining FREE SPACE, the option for "Bootable flag:" is present but remains "off" even when I hit enter.

Every time I try to change it, it briefly flashes a window that says "Computing the new state of the partition table" then returns to the Partition disks screen, with the Bootable flag still set to "off."

How can I set the bootable flag to "on?"

  • Chances are you don't need it. What partition table does your disk use -- MBR (called "ms-dos" by some tools) or GPT? Also, what tool are you using to try to change the boot flag? – Rod Smith Oct 5 '15 at 13:38
  • @RodSmith I am using this walkthrough: help.ubuntu.com/14.04/serverguide/advanced-installation.html There was also no option to choose "Primary" as it indicates to do in Step 4, if that helps. – Willman Oct 6 '15 at 15:11
  • Just a guess, but you may be booting in EFI/UEFI mode, in which case you'd be using GPT, on which there's no such thing as a primary partition (although some tools call all GPT partitions "primary"). On GPT, you should not set the "boot flag" on anything but the EFI System Partition (ESP). I've only skimmed the procedure to which you link, but I don't think there's any need for a boot flag with that procedure, even when using MBR. Type sudo parted /dev/sda print | grep Table to determine your partition table type with certainty. – Rod Smith Oct 6 '15 at 15:19
  • Just as an information for people who stumble about this: This is a pretty old bug of the debian-installer ( bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/477167 ) since Ubuntu 9.10 at least. So far it is still present in 16.04 (maybe newer versions as well). I think that modern setups doesn't rely on the boot flag anymore anyway but I'm not sure about it and nevertheless it's still a bug. – alexanderadam Jun 28 '17 at 5:59
2

I realize this is an old post, but I am still installing Ubuntu Server 14.04 and have found this issue as well. As far as I can tell it is from booting with EFI/UEFI media, as Rod Smith has stated.

I ran the install using a USB jump drive with the Ubuntu Server 14.04.4 ISO and the intention of installing in BIOS mode. In the BIOS menu I selected to boot from USB. The install ran normally and I created the partitions as desired (using 500mb ext2 in raid1 for the /boot partition) but I could not change the boot flag. Also, the partitioner did not ask for primary/logical partitions. The installer ran until the GRUB install, then failed. I attempted this multiple times with install variations with the same result.

Next I ran the install from a CD with the same ISO. I set up the partitions the same way and was able to set the bootable flag to on and also select primary/logical. The install then worked as expected and the GRUB install worked with complaint.

I am still new to installing and have not figured out all the details of BIOS/UEFI, but as far as I can tell this is where the issue lies.

| improve this answer | |
0

The same was for me. The difference was indeed it was a difference between uefi and BIOS.
My fix was to add a 3rd partition of 400mb and make that an EFI partition. After this the installation succeeded.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.