3

I use the English (US, Alternative international) layout, which allows me to type some characters (ç, á, ã, etc.), but when I start Ubuntu and try to type any of these characters, it becomes 'c, ~a, etc. When I re-select the same keyboard layout, it works!

Why is it happening? How can I fix it?

Thanks!

0

Assuming your Ubuntu version is above 12.04 you can change the default keyboard layout by editing the keyboard layout file:

sudo vim /etc/default/keyboard

and change the XKBLAYOUT option to "us-intl"

Reboot your system and test the new layout.

  • It didn't work... – Rafael Telles Oct 17 '15 at 12:27
  • Is your Ubuntu version above 12.04? – Hugo Sadok Oct 17 '15 at 14:35
  • Yes, its 15.04. – Rafael Telles Oct 17 '15 at 15:33
0

You can reset your keyboard layout in the terminal with sudo dpkg-reconfigure keyboard-configuration

  • I don't think this is really an answer to the question. – TheWanderer Oct 15 '15 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.