23

I upgraded to ubuntu 11.10 from 11.04, shocked to see few things...

My system is behind a proxy, so I did set a proxy setting. Being a web developer, I want to remove a lot of addresses that I type in browser address bar to not hit proxy. There's no such ignore list in ubuntu 11.10, what/where do I do it? What was the requirement to change the way network gui worked?

1 Answer 1

31

I found a hint to the solution in Ubuntu Forums, where a user sent a link to Gnome Developer Center explaining the configuration for Gnome Shell. My solution explains what to do for Unity.

You will need to install dconf-tools if you don't have it yet:

sudo apt-get install dconf-tools

Then run the tool (for example, pressing Ctrl+F2, then typing dconf-editor and pressing Enter).

Expand the key system on the left pane and click on the proxy key. On the right pane you will get the place to enter the list of ignored proxies (ignore-hosts).

In the key proxy and subkeys of it (ftp, http, https and socks) you can configure more proxy options that are not available in the new-shiny-but-almost-useless GUI.

Don't forget to log out and log in again to make the configuration active!

The only difference for Unity compared with Gnome Shell is that the keys to be modified for Gnome Shell are in the org.gnome.system.proxy key.

4
  • 1
    BTW, you might want to amend "dconf" to "dconf-editor", otherwise thanks! Dec 19, 2011 at 7:59
  • @khoomeister: thank you for your comment! I already corrected the mentioned command.
    – silvavlis
    Jan 9, 2012 at 15:04
  • great - although many third party softwares don't honor those settings yet :(
    – Shrinath
    Apr 25, 2012 at 5:42
  • Hello, I recently see this post, install the dconf editor and filled the options. But now I can log in in to my account. Any Idea Nov 14, 2014 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.