0

I'm running 15.04. Since latest updates few days ago of ubuntu base and kernel, I have incurred in the following issue, which only happens occasionally at some point (and to resolve it I have to restart):

  1. When clicking on a icon in the unity launcher sidebar, the app won't open (some will 'flash' the glass background for a while, the cursor will show the 'loading' spinner while hovering unity sidebar, but no matter what, the apps won't start

  2. When clicking/opening the dash and launching an app from the keyboard, the behaviour is the same, app won't start, if I move the mouse over the unity sidebar, spinning loader cursor appears for a while, no app open

  3. In programs already opened, if I click on one link that is supposed to open a new tab in the browser (for example from Thunderbird message to Chrome), this won't work anymore, I need to copy and paste it

  4. Existing programs will continue to work, unless I close them, after that the only way to restart is to restart the whole machine, until the problem happens again

  5. Shortcuts to open programs (e.g. terminal) won't work (with some exception, e.g. nautilus).

I've seen sometimes the problem disappearing even without restart, after a while. But have no idea what triggers this. I can't open the task manager so I don't know what's running and if my terminal is closed I can't do much.

Tried reinstalling unity or compiz as already suggested but nothing changed. The system is stable, all the rest seems to be working fine.

  • 1
    Have you tried reinstalling compiz? – TellMeWhy Oct 2 '15 at 14:08
  • thanks, would this suffice? sudo apt-get install --reinstall compiz – unfulvio Oct 2 '15 at 14:09
  • 2
    Possible duplicate of How can I remove and re-install Unity? – TellMeWhy Oct 2 '15 at 14:12
  • no, it's not a the duplicate, the answer there didn't solve my problem – unfulvio Oct 2 '15 at 23:41
  • Looks like I have a similar problem on my 15.04. Doesn't try to reisntall Unity or anything else (will upgrade system soon), but have found the method to restart Unity without closing any apps: unity --replace & (in Terminal). – Alex Belyaev Sep 29 '16 at 8:09
0

It could be a problem with compiz, which you can solve by reinstalling compiz.

Remove compiz:

sudo apt-get remove compizconfig-settings-manager
sudo apt-get remove compiz-fusion-plugins-extra
sudo apt-get remove compiz-plugins-extra
sudo apt-get purge compiz*

Reinstall compiz:

sudo apt-get install unity-2d
sudo apt-get install ubuntu-desktop
sudo apt-get install ubuntu-desktop-2d
sudo apt-get install compizconfig-settings-manager
sudo apt-get install xserver-xgl
sudo apt-get install emerald
sudo apt-get install compiz-fusion-plugins-extra
sudo apt-get install compiz-plugins-extra
sudo apt-get install unity
| improve this answer | |
  • would this suffice? sudo apt-get install --reinstall compiz ? – unfulvio Oct 2 '15 at 14:30
  • @nekojira I'm not sure... – TellMeWhy Oct 2 '15 at 14:30
  • what happens while running those commands on terminal? will the GUI disappear? what should I expect? – unfulvio Oct 2 '15 at 17:15
  • ps I ran --reinstall and problem persisted, so I'm keen to do as you suggest but need to be sure not to cause major fu...ps :) – unfulvio Oct 2 '15 at 17:16
  • I tried the proposed answer but ran into problems which I then solved. Managed to reinstall compiz, unity etc. But the error persists. – unfulvio Oct 2 '15 at 23:41
0

I have the same problem, Ubuntu freezes randomly and then I hear the app crash sound, and I can no longer open apps via unity launcher.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.