1

I installed 14.04 on a machine with an NVIDIA Quadro K600 connected to two LG "Goldstar Company Ltd" 22 inch monitors. One on the DVI port and one on the HDMI port. I was initially happy with the open source Nouveau driver. Everything worked as expected with the monitors using their native resolution. Then I discovered the Nouveau driver wasn't providing hardware acceleration to my VMWare (Windows 7) virtual machine. So I switched to the proprietary tested NVIDIA driver (version 346.96).

At that point I found the second monitor, the one on the DVI port was not configured properly. The information that had previously been detected (I assume via EDID) for this monitor was no longer present. It was available as a generic monitor with a maximum resolution of 800x600 - well below the 1920x1080 it supports. The /var/log/Xorg.0.log also showed many lines of text saying that the EDID information contradicts itself. It's unclear whether that is of relevance. Is it possible the system was trying a poor configuration with the pair a single 3840x1280 monitor?

In any case, I'm sure I need to produce a custom /etc/X11/xorg.conf file, but the NVIDIA tools included with the driver were not useful. Can you help? Please let me know if you'd like to see files etc.

Regards, Phil

0

Solved this problem yesterday. In case anyone runs into the same issue, here is some information.

Strangely, I discovered that if I unplug the second monitor, allow the system to revert to a single monitor then plug it back in, it is occasionally detected and switched to the correct resolution. Despite this, the nvidia-settings tool always generates the same xorg.conf file. However, using it in /etc/X11/xorg.conf caused the system to show the correct screen resolution at login, but then repeatedly return to the prompt after entering the correct login credentials. It had to be removed in order for a successful log in to occur.

I found this page on the Xorg wiki (https://wiki.archlinux.org/index.php/NVIDIA#Multiple_monitors) and tested appropriately modified versions of the two custom xorg.conf files under the "ConnectedMonitor" and "TwinView" sections. I found that they both worked! For a few seconds... After logging in the system would automatically switch monitor modes a few times before settling for about 10 seconds and then showing the following message, that could not be closed or made to disappear:


Could not switch the monitor configuration
could not set the configuration for CRTC 731
| Close |


At that point the processor usage went up, and the system became unusable. The System Monitor revealed that Xorg was responsible. I can only imagine that the process and system was occupied with displaying the same message repeatedly.

Coupled with this page (https://a248.e.akamai.net/f/248/10/10/us.download.nvidia.com/XFree86/Linux-x86/185.18.14/README/appendix-b.html) I discovered that the common element is the "ConnectedMonitor" option. I created a custom xorg.conf file that fixed the problem. Here it is in its entirety:

Section "Screen"
    Identifier     "Screen0"
    Option         "ConnectedMonitor" "DFP, DFP"
EndSection

The only strange behaviour the system exhibits now is second monitor toggling between its native and an 800x600 resolution when I open the unity-control-center and the "Screen Display" panel. However, I have resigned myself to this being as good as things will get.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.