84

How can I create a keyboard shortcut so that when I press F12 in nautilus (or desktop), I get a terminal in the current directory?

3

9 Answers 9

52

Edit: not anymore applicable for Ubuntu 16.10 and newer

Finally figured it out.. first sudo apt-get install dconf-tools nautilus-open-terminal, then run dconf-editor and set the org/gnome/desktop/interface/can-change-accels boolean on. Then open nautilus using this command (to disable Unity global menu Temporarily):

nautilus -q
UBUNTU_MENUPROXY=0 nautilus

Now you can mouseover the action in the file menu, and change the accel by typing your key while the action is highlighted, finally restart your nautilus. If you don't see Open in terminal in the File menu and you've just installed nautilus-open-terminal, you might need to first run nautilus -q.

enter image description here

enter image description here

Ubuntu 14.04 and up

If you can't find the can-change-accels key in your dconf configuration you can try the following solution:

  1. Stop nautilus by executing nautilus -q

  2. Open ~/.config/nautilus/accels in a text editor of your choice, e.g. gedit:

     gedit ~/.config/nautilus/accels
    
  3. Try to see if you can find the following line:

     ;(gtk_accel_path "<Actions>/DirViewActions/OpenInTerminal" "")
    
  4. If the line exists, add your keyboard shortcut in the second double-quoted segment and uncomment the line by removing ;:

     (gtk_accel_path "<Actions>/DirViewActions/OpenInTerminal" "F12")
    

    This would set the shortcut to F12. For a list of all possible key codes please consult this answer.

    If the line doesn't exist just copy and paste the one found in this answer at the end of the file.

  5. Save the file and restart Nautilus by clicking on the Nautilus icon in your launcher/dash.

Ubuntu 15.10 and 16.04

Here, the relevant command in ~/.config/nautilus/accels is TerminalNautilus:OpenFolderLocal. (NautilusOpenTerminal::open_terminal is still present in the file, but doesn't seem to have any effect.) So follow the instructions above, except change the line

; (gtk_accel_path "<Actions>/ExtensionsMenuGroup/TerminalNautilus:OpenFolderLocal" "")

to

(gtk_accel_path "<Actions>/ExtensionsMenuGroup/TerminalNautilus:OpenFolderLocal" "F12")

to make F12 your keyboard shortcut. Notice that ; is again removed.

Finally, log out for changes to take effect.

12
  • The trick with F12 key doesn't work for me :( May 30, 2013 at 9:52
  • 1
    As indicated in the answer, use dconf-editor. Using gconf-editor may not help.
    – Kadir
    Sep 1, 2013 at 5:06
  • 1
    Worked in Ubuntu 16.04 but seems not working for 16.10. Feb 17, 2017 at 18:42
  • 1
    not working in 17.10..
    – jkokorian
    Feb 3, 2018 at 11:13
  • 2
    According to the other answer this answer has not been functioning for quite a few versions of Ubuntu now. This should be edited into the answer more clearly! Could someone do this. Alternatively please upvote comments that indicate that this no longer works for 16.10 and newer.
    – Kvothe
    Nov 17, 2020 at 15:14
34

Since version 3.15.4 Nautilus doesn't load the accel file anymore (Source).

Fortunatelly there's a better aproach in order to get what you want. Long explanation/useful resources can be found here and also here. In short:

  1. Create a script called Terminal (yes, without a extension) inside the folder ~/.local/share/nautilus/scripts with the following content:

    #!/bin/sh
    gnome-terminal
    
  2. Make it executable, then close any Nautilus instance:

    $ chmod +x Terminal
    $ nautilus -q
    
  3. Create (or edit) the ~/.config/nautilus/scripts-accels file adding these lines:

    F12 Terminal
    ; Commented lines must have a space after the semicolon
    ; Examples of other key combinations:
    ; <Control>F12 Terminal
    ; <Alt>F12 Terminal
    ; <Shift>F12 Terminal
    
  4. Test it! Open Nautilus, right click, and choose Scripts > Terminal. Or, use the keyboard shortcut that you've just configured :)

Note: Tested on Ubuntu 18.04.

Update Ubuntu 20.10: Unfortunately, this does not anymore work in Nautilus 3.38 (Ubuntu 20.10).

Update Ubuntu 21.10: Fortunatelly, the scripts-accels file works again in Files 40 (Ubuntu 21.10)

11
  • 2
    Thanks, confirmed working in Ubuntu 18.04 <3
    – Karlsson
    Feb 22, 2019 at 9:56
  • 2
    Still works for 19.04. Thanks!
    – Alex K.
    May 27, 2019 at 19:04
  • 1
    Still works for Ubuntu 18.04.2. Thanks you!
    – JJD
    Jul 11, 2019 at 20:43
  • Thanks, working in Ubuntu 18.04
    – Naami
    Sep 2, 2019 at 21:09
  • 5
    Works on Ubuntu 20.04 LTS! 🎉
    – Salim B
    May 8, 2020 at 16:16
13

Using the dconf-editor approach doesn't seem to work in Trusty Gnome. But the following does:

In your home directory press Ctrl+h, open the .config folder, the nautilus folder, and the accels file;

ie, open ~/.config/nautilus/accels and change the line:

; (gtk_accel_path "<Actions>/ExtensionsMenuGroup/NautilusOpenTerminal::open_terminal" "")

to

(gtk_accel_path "<Actions>/ExtensionsMenuGroup/NautilusOpenTerminal::open_terminal" "F12")

Note that the comment delimiter has been removed.

Save the file, log out and back in.

6
  • 3
    Yep, this is the approach I have already suggested in the comment on accepted answer.
    – wim
    May 7, 2014 at 14:09
  • This approach works perfectly
    – Hasan
    Mar 29, 2015 at 15:43
  • 2
    There is no need to log out and in again. A simple nautilus -q does the job.
    – adn
    Apr 20, 2015 at 14:31
  • I tested this on 3.28.1 and it didn't work. Can someone please test with the same version?
    – orschiro
    Jul 18, 2018 at 11:10
  • I didnt't find that line Aug 18, 2018 at 1:03
10

Not exactly the answer for this question
If all you want is access the terminal in the current directory, you can do that with
Ctrl + F10 then e

Ctrl + F10: Same as right click at the current directory
e: Selects "Open in Terminal"


It can change if your OS is in another language.
For example, in portuguese from brasil would be:
Ctrl + F10 then t
Just look at the underlined letter to know the key.


If you are using notebook you may have to use the super key too.
Ctrl + Super + F10 then e


You mentioned opening from Desktop, the closest i could think is opening the terminal on home directory.
Ctrl + Alt + t

3
  • 2
    Valid answer, provided you indicate this is a (quite valid) workaround rather than a possibility to add a shortcut key.
    – vanadium
    Feb 13, 2021 at 12:15
  • 1
    thank you countryman. Jul 2, 2021 at 4:20
  • This should be community wiki, lol Jan 30 at 0:41
6

You could also use a nautilus script instead of a dedicated extension:

#!/usr/bin/perl -w
#
# Open terminal here
#
# Nautilus script that opens a gnome-terminal at the current location, if it's
# a valid one. This could be done in shell script, but I love Perl!.
#
# 20020930 -- Javier Donaire <jyuyu@fraguel.org>
# http://www.fraguel.org/~jyuyu/
# Licensed under the GPL v2+
#
# Modified by: Dexter Ang [thepoch@mydestiny.net]
# 2003-12-08: Modified for Gnome 2.4
#       - Added checking if executed on Desktop "x-nautilus-desktop:///"
#         so that it opens in /home/{user}/Desktop

use strict;

$_ = $ENV{'NAUTILUS_SCRIPT_CURRENT_URI'};
if ($_ and m#^file:///#) {
  s/%([0-9A-Fa-f]{2})/chr(hex($1))/eg;
  s#^file://##;
  exec "gnome-terminal --working-directory='$_'";
}

# Added 2003-12-08 Dexter Ang
if ($_ == "x-nautilus-desktop:///") {
  $_ = $ENV{'HOME'};
  $_ = $_.'/Desktop';
  exec "gnome-terminal --working-directory='$_'";
}

Instructions on installing the script and assigning a keyboard shortcut.

3
  • 1
    And how exactly having a Nautilus script instead of a dedicated extension helps assigning it a keyboard shortcut?
    – MestreLion
    May 30, 2014 at 8:58
  • 1
    @MestreLion Thank your for your comment. This answer was merged from another Q&A (check the edit log for more details). That's why it didn't have a section on assigning a shortcut. May 30, 2014 at 13:06
  • Ohh, I see. Sorry then! A bit unfortunate that such distinct (albeit related) questions were merged. Your answer was great for the other question, but incomplete for this one.
    – MestreLion
    Jun 1, 2014 at 12:50
3

To expand on John F. Healy's post:

nautilus -q
sudo apt-get install nautilus-open-terminal
sed -i 's/; (gtk_accel_path "<Actions>\/ExtensionsMenuGroup\/NautilusOpenTerminal::open_terminal" "")/(gtk_accel_path "<Actions>\/ExtensionsMenuGroup\/NautilusOpenTerminal::open_terminal" "F12")/g' ~/.config/nautilus/accels

This should work on Ubuntu 14.10 Utopic Unicorn. The last line edits the ~/.config/nautilus/accels file. To make sure the edit was successful, try the following command:

grep NautilusOpenTerminal::open_terminal ~/.config/nautilus/accels
2

After installing nautilus-open-terminal, ensure that you have killed all nautilus processes (there's always one non visible nautilus process running, so use pgrep nautilus to find them and use then use the kill command).

Then if you launch nautilus, you should see the Open in Terminal if you right-click in the list of files, like I did in the screenshot below (where I was running 14.04):

enter image description here

1
  • 4
    The problem is I use list view where there is no white space left if the folder contains many files. Now I use tree in list view in the display setting as a temporary solution.
    – xgdgsc
    Apr 10, 2014 at 11:19
1

Besides configuring by hand, there is also a GUI application to manage these shortcuts: https://github.com/echo-devim/nautilusaccelsmanager (tested)

It's pretty useful since the configuration fails because of tiny stuff like capitalization. With this useful tool, just press the desired hotkeys and configuration with the right style is produced.

For a detailed insight of how it works, see https://askubuntu.com/a/696901/1147792.

-1

I would do a right click in your file browser or desktop with

alt+click

Then find the "Open in Terminal" option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.