I connect with VPNC and get the message:

VPN connection was successfully established.

and a lock in the WiFi icon in the upper-right corner of Ubuntu Desktop appears.

How to check that VPNC really works?

More about this problem:

I've just got a new laptop and installed Ubuntu 14.04 and all its updates. Before installing/configuring anything else, I tried to ssh to our local server secured with VPNC. I just installed VPNC following these steps: which really installs the package called network-manager-vpnc. Then I establish VPNC connection, and get the message about the success and the lock on the WiFi icon.

Then I try to ssh to the server. But I get an error, which is the same as if VPNC was not on:

ssh: connect to host “xxx” port 22: Connection timed out

It seems to me that the lock signals a functioning VPNC, but the VPNC actually does not work.

Note that:

  • When I try to establish the VPNC connection (by clicking on the WiFi icon, then VPN Connections, and then on 'Some of My VPNC Connection Names') nothing happens. I need to try several times before the WiFi icon starts flashing. The flashing is then reliably followed be the appearance of the lock, which remains there and does not go. But, again, to get it flashing may take several attempts.
  • I tried two installations of Ubuntu 14.04 on two different laptops (3 laptops in total). The were installed from different USB sticks/CDs and downloaded and created at different times. The problem is the same on all laptops: Connection timed out.
  • Also I tried another two laptops of my colleague, both running Ubuntu 14.04. I could ssh via VPNC without any problems using my details. More on that is here.

2 Answers 2


I have fixed the problem by only connecting via vpnc and not using network-manager-vpnc. Look at the reply by seedkhan here or my reply here. The fact that vpnc works but not with network-manager-vpnc on a freshly installed ubuntu suggests that there may be a bug in network-manager-vpnc.


You can check by running ifconfig and checking for VPN related entries (usually tun0 or pptp0 or something similar). Alternatively, there are a number of websites which will display your IP address as they see it, e.g. google. Switch the VPN connection on & off, and check whether the address changes.

(See also my related question and a bug which has similar symptoms. Following the troubleshooting procedures from that bug report may help you further.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.