4

The option for disabling the touchpad while typing does not work in Settings/Mouse & Touchpad in Ubuntu 15.04 (The setting seems to be gone in 15.10??)

I have tried installing 'Pointer Devices' from the software centre, it did not help (settings did not get persisted).

I have seen this and it did not help; I have restarted syndaemon with syndaemon -i 1 -KRd and I can still move the mouse while typing.

Is this a bug? Are there any workarounds?

Could this be caused by a tochscreen being present along with a touchpad?

~$ xinput --list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ USB Optical Mouse                         id=10   [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                          id=11   [slave  pointer  (2)]
⎜   ↳ DLL0665:01 06CB:76AD UNKNOWN              id=13   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=16   [slave  keyboard (3)]

Laptop model is Dell XPS 13 9343

0

I use Touchpad-Indicator, a very flexible app. It is not available from Ubuntu repositories, so you need to add one manually.

  • Latest version: add the repository with

    sudo add-apt-repository ppa:atareao/atareao

Then, install as usual:

sudo apt-get update
sudo apt-get install touchpad-indicator

To obtain desired option (disable touchpad while typing), Open the program and select that option from Preferences -> Actions.

Don't forget to add the app to the startup list, so this is always enabled. You can do this within the same program, from Preferences -> General options tab.

Now it should work. If it does not work at the beginning, restart the computer/session (some users mention that as an extra step).

If it still does not work, it might be because of this bug. The workaround is to create an empty configuration file that the program is unable to create itself. This is how (using the terminal):

mkdir ~/.config/touchpad-indicator
echo '{}' > ~/.config/touchpad-indicator/touchpad-indicator.conf 
sudo chmod 777 ~/.config/touchpad-indicator/touchpad-indicator.conf 

Then open the program and configure it again. You can then check that the new configuration variables are inside that file.

  • Older version (14.04 Trusty, known to work):

If for any reason it still does not work, then try a different version of the program. First, if tried the method above, uninstall it with:

`sudo apt-get purge touchpad-indicator`

Also, remove ppa with:

sudo rm /etc/apt/sources.list.d/atareao-atareao-trusty.list
sudo rm /etc/apt/sources.list.d/atareao-atareao-trusty.list.save

Then, add this ppa:

sudo add-apt-repository ppa:baltix-members/ppa

If you are not using Trusty, then you need to change the ppa version. Go to /etc/apt/sources.list.d/, open the above ppa (called baltix-members-ppa-trusty.list) and edit the ubuntu version so that the files contain trusty as below:

deb http://ppa.launchpad.net/baltix-members/ppa/ubuntu trusty main

Then install:

sudo apt-get update
sudo apt-get install touchpad-indicator
6
  • Unfortunately this does not work for me. I have installed the app, configured it to disable touchpad when typing, restarted and I can still move the cursor while typing. – Zoltan Jul 25 '16 at 14:44
  • Updated answer with bug info and new ppa. – user308164 Jul 25 '16 at 19:49
  • Hello, thanks a lot, but it still does not work :( The .conf file was there already, so I skipped creating it and jumped straight to adding ppa:baltix-members. I have removed ppa:atareao though, as I figured it won't be able to find out where to download it from. With this config touchpad-indicator is not found. – Zoltan Jul 26 '16 at 14:32
  • Updated the answer (the ppa has to be set up for Trusty). Also, check that the .conf files has the writing rights as required. Run the chmod command anyway. – user308164 Jul 26 '16 at 15:45
  • Hey, thanks a lot, it has found the new touchpad-indicator in ppa:baltix-members now, but it still have not fixed the issue. The file has write priviledges, my settings were saved each time I modified the config. I have also restarted my machine to make sure. I have added extra info to my original question. – Zoltan Jul 28 '16 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.