0

I have problem with virtual box. It worked fine for some time then after update on ubuntu 15.04 I am getting this error:

WARNING: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (3.16.0-34-generic) or it failed to load. Please recompile the kernel module and install it by

       sudo /etc/init.d/vboxdrv setup

     You will not be able to start VMs until this problem is fixed.

I can run Virtual box but I can't run any virtual machine inside of it, I get this error

The virtual machine 'Win XP2' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: MachineWrap Interface: IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}

Any help would be great, thanks in advanced.

  • Did you run sudo /etc/init.d/vboxdrv setup ? It needs build-essential pcket installed too. – Barafu Albino Sep 30 '15 at 10:53
  • Which version is Virtual Box? – h0ch5tr4355 Sep 30 '15 at 10:53
  • After runing sudo /etc/int.d/vboxdrv setup i got this error: Stopping VirtualBox kernel modules ...done. Uninstalling old VirtualBox DKMS kernel modules ...done. Trying to register the VirtualBox kernel modules using DKMSError! Your kernel headers for kernel 3.16.0-34-generic cannot be found. Please install the linux-headers-3.16.0-34-generic package, or use the --kernelsourcedir option to tell DKMS where it's located ...failed! (Failed, trying without DKMS) Recompiling VirtualBox kernel modules ...failed! (Look at /var/log/vbox-install.log to find out what went wrong) – guber90 Sep 30 '15 at 10:56
  • Also I use Virtualbox 5.0.4 – guber90 Sep 30 '15 at 10:58
1

I found solution, installed latest kernel and header files for it, then I run: sudo /etc/init.d/vboxdrv setup

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.