I just freshly installed Ubuntu 15.04 from an USB pendrive to my Toshiba Satellite U940.

Normally this works great, but this time it was a real struggle.
I had several issues regarding grub2, installation failed due to grub and so on. Now I finally managed to get it working but my EFI doesn't boot from the SDD. I also tried boot-repair of course. Still no bootable device according to the EFI. I managed to get a few lines of output by my PC via a slowmotion video. It says:

Failed to open \EFI\BOOT\grubx64.efi - Not Found

Failed to load image \EFI\BOOT\grubx64.efi - Not Found

and a few lines I can't properly read.

Boot-repair pastebin url is: http://paste.ubuntu.com/12623394/

I'm booting in UEFI mode, all secure boot measures disabled. No dual-boot, all harddrives fully deleted before install. However I'm installing Ubuntu and grub on /sdb not /sda, as sdb is my SDD and sda my HDD. Can this cause problems? Boot order is set to boot first from SDD.


There are several odd things about your setup:

  • Your /dev/sda (a Toshiba MQ01ABD075_Y216FCTCS) is present, but doesn't appear to have a partition table or filesystem. This might be expected and harmless, depending on what that device is, but it's unclear what's causing this oddity.
  • Your /dev/sdb (a Samsung MZMPC032HBCD) is partitioned using the Master Boot Record (MBR) partition table, but EFI-bootable disks normally use the GUID Partition Table (GPT).
  • Your EFI System Partition (ESP) is a logical partition on /dev/sdb (it's /dev/sdb6, to be precise). This might work, but only if your firmware isn't too finicky and if the NVRAM contains a pointer to the boot loader or if it's installed as EFI/BOOT/bootx64.efi. At best, this is highly unusual.
  • The Boot Repair script turned up no evidence of any EFI boot loaders on /dev/sda or /dev/sdb. (/dev/sdc seems to be your emergency boot USB drive.) This is probably a bug in Boot Repair, but it makes it hard to judge what's actually booting.

Overall, I'd say you need to repartition /dev/sdb to use GPT. (You can completely repartition it or use gdisk to convert it from MBR to GPT.) The Ubuntu installer should use GPT when it's fed a blank disk for an EFI-mode installation; however, it might stick with MBR if it's fed a pre-partitioned MBR disk. (I've not studied what the Ubuntu installer does in such a case -- and it might do different things depending on the Ubuntu version.) Alternatively, you need to mount /dev/sdb6, figure out where your boot loaders are, and adjust their paths appropriately; or use efibootmgr to create an entry that points to the boot loader. You might want to read my page on EFI boot loaders, and especially the sub-pages on EFI boot principles and installing EFI boot loaders, for more information. The inline links earlier provide background information, and so are worth reading, too.

  • My desktop has two drives. My main working install is in sda, gpt partitioned with the ESP. I created gpt on sdb, with an ESP partition. And every install to sdb has overwritten my /EFI/Ubuntu in sda. Grub is hard coded to only install to sda. It even said during install "installing to sdb" but overwrote efi partition on sda. I could only get an UEFI install to my sdb by disconnecting sda, making sdb really sda. But then UEFI reconfiguration lost that sdb configuration when I plugged sda back in. – oldfred Oct 4 '15 at 15:19
  • Thanks for the answer. The /dev/sda is not of interest as its a storage only HDD. What I don't understand is, why the Ubuntu installer didn't format the disk with a GPT partition table. I've reformatted it using the installer several times. Most of the installations caused a crash reporting grub2 couldn't be installed. Sometimes I was able to chose a different drive for grub installation, sometimes I don't. When finally getting it to not crash by simply repeating installation my EFI didn't detect a boot loader so it seems to be the case it was using a MBR partition table. – Dustin Wortmann Oct 4 '15 at 15:57
  • Does the ESP have to be a primary or logical partition? – Dustin Wortmann Oct 4 '15 at 15:57
  • Normally the ESP is neither primary nor logical because it's on a GPT disk, which doesn't use those concepts. (Some tools report all GPT partitions to be "primary," but that's because of limitations of those tools.) You may need to partition the disk manually before you start and use the "something else" installation option. Be sure the ESP is marked as such in the installer. (Some versions of Ubuntu installer call it an "EFI boot partition.") GRUB should install there when it's properly marked, but I can't promise that; there could be bugs like oldfred describes. – Rod Smith Oct 5 '15 at 13:00

What helped was to not manually format the disks, rather let Ubuntu do the job. Strangely, no matter what I set as formation order etc., it didn't work. But when Ubuntu did it and formatted it as I did, it worked. Maybe the installer has trouble recognizing the EFI system partition. Or it's just a specific problem of my notebook.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.