I added a second user 'shirley' in Settings -> User Accounts, and set a password. The account type is Standard. In 11.04, this worked and I logged in and had a functioning desktop for this user.

How is this done in 11.10? When I try to log in as this user I have this error:

Nautilus could not create the required folder "/home/shirley/.config/nautilus". Before running Nautilus, please create the following folder, or set permissions such that Nautilus can create it.

The only option then is to click OK, this dumps me out to full-screen Nautilus, like this: desktop

There is no launcher or visible way to start any programs. Print screen doesn't take a screengrab. The desktop is similar to this question but I get no terminal when I press CTRL+ALT+T. I have to press CTRL+ALT+F2 and restart from the terminal to get out of this. This answer is to install gnome-system-tools. Shouldn't I be able to add a second user with the default install?

EDIT: I tried the deluser+adduser suggestion, there was no change after trying it. Here is what I got:

tom@desktop:~$ sudo deluser shirley

[sudo] password for tom:

Removing user `shirley' ...

Warning: group `shirley' has no more members.


tom@desktop:~$ sudo adduser shirley

Adding user `shirley' ...

Adding new group `shirley' (1001)

Adding new user shirley' (1001) with groupshirley'

The home directory '/home/shirley' already exists. Not copying from `/etc/skel'.

Enter new UNIX password:

Retype new UNIX password:

passwd: password updated successfully

Changing user information for shirley

Enter the new value, or press ENTER for the default

 Full Name []:

 Room Number []:

 Work Phone []:

 Home Phone []:

 Other []:

Is the information correct? [Y/n] y

What has gone so wrong with simply adding a second user? Am I the only one having this problem? I'd reinstall if that fixed things, but this is a fresh install only a few days old.

3 Answers 3


It looks like you have a directory already called shirley, so when it creates a new user it doesn't copy the needed files from /etc/skel, which is needed to run things.

Let's try removing the directory and doing it from scratch, but before you do, look in /home/shirley and make sure there's no data there that's important:

sudo deluser --remove-home shirley
sudo adduser shirley 
  • Those are particularly dangerous and typo-prone commands. Better to recommend running deluser --remove-home , or at the very least to remove the folder using ~shirley rather than /home/shirley. Oct 17, 2011 at 17:23
  • @ImaginaryRobots Feel free to edit my answer! Oct 17, 2011 at 17:26
  • edited. :) side effect is that it's fewer commands too. Oct 17, 2011 at 17:28
  • SUCCESS! Many thanks to all for the help. Not sure what went wrong originally, but I know how to fix it now. Oct 17, 2011 at 19:55

As a temporary fix, open up a terminal with ctrl-alt-F2, (you can return to your original session with ctrl-altF7) login then type


Then recreate the user with:


This should create the home folders and allow login

Kind Regards

  • Didn't work. After trying this, I got a message saying "The home directory '/home/username' already exists. Not copying from '/etc/skel'." After a reboot and login, I still have nothing but a monochrome desktop background with a file menu at the top, nothing else. No launcher, etc. The hardware easily supports Unity, that's not the issue here either. Thanks for the reply, anyway. Oct 17, 2011 at 10:35
  • @JE2Tom it looks like you need to sort out what's going on with your desktop before trying to add another user user via the GUI, though it looks like you might be trying to create an account that already exists? Oct 17, 2011 at 12:39
  • @Jorge any suggestions? This is a fresh install, nothing special. I just want to add a second account for my wife on the computer. This was always really easy before 11.10. Now I am having this strange problem. Should I ask the question differently? Feel free to edit the original. Oct 17, 2011 at 14:13
  • @jE2tom Can you edit your question with what happens when you try to deluser and adduser again? Oct 17, 2011 at 14:19
  • Done, see above Oct 17, 2011 at 17:05

It's complaining that a specific folder doesn't exist, so it may be as simple as creating that folder manually.

Open a terminal and type:

sudo mkdir -p /home/shirley/.config/nautilus/

Then try logging in as that user.

As to why this isn't working by default, that sounds like a bug that should get reported to ubuntu.

  • This might have worked, but I didn't try it. I was worried that it might have just provided a workaround, with more problems later... I'll look into the bug report, too. Thanks anyway. Oct 17, 2011 at 20:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .